cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Help required on assigning system ID for models being done in Creo/Direct

Highlighted
Newbie

Help required on assigning system ID for models being done in Creo/Direct

Hi,

 

I require a clarification on Creo Direct system ID for model.

 

While I upload the files in Windchill it shows conflictions if all Creo Direct models assigned into same systems ID. So the customer wanted to change the system ID of each model created in Creo Direct.

 

Please help me in solving this issue.

 

Thank you,

Sreedharan

4 REPLIES 4

Re: Help required on assigning system ID for models being done in Creo/Direct

Hi Sreedharan,

Can you clarify the Cad App? Creo Elements/Direct 18.x or Creo Direct 2.0?

If you mean Elements/Direct (this forum), then i guess you are using the Windchill WGM?

Unlike Model Manager, i don't believe there is an "Assign New SysID" (if anybody can correct me on this, i would be interested to know where this function is)...

So if that is the case, you will need to copy the existing part in Elements/Direct Modeling, and this will generate a new sys id on the part.

Additionally, I am curious as to why you wish to 'change the sys id' of models. The message that you are seeing is indicating that this part already exists in this db. The only reason for changing the sys id of the non db part is if you require a new part to be created - is this your intention?

Apologies if i have mis understood your request or your query is not related to the Elements/Direct products.

Thanks

Barry

Re: Help required on assigning system ID for models being done in Creo/Direct

Hello!

Did you solved your issue?

I need the same thing now.

I need to fix corrupted assemblies with missing parts then I need to create empty parts with the missing SYSID.

I saw commercial solutions (like http://www.cadadlatus.de/Anleitung_SysID_Change.pdf) but which is the trick?
Which is the hidden function to do it?

Thanks

Re: Help required on assigning system ID for models being done in Creo/Direct

There are a couple of ways to change the System ID, but it depends on what you are trying to achieve.

 

The easiest way to change it is to make a copy of the part. The copy will have a different System ID. Copy the Model Number if necessary, and then delete the original. This works well if the part had never been saved before.

 

I haven't saved to the Windchill database much; I use Model Manager instead. With the Model Manager interface there is an option to 'Assign new SysID to local model' when there is a System ID conflict.

Re: Help required on assigning system ID for models being done in Creo/Direct

Hello Peter,

I need to set a specific SYSID, not a new one.

I don't have Model Manager.

 

Thanks

Nicola