cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mechanica Loop

Highlighted
Newbie

Mechanica Loop

I've been running various design iterations on a model, basically adding
a simple rib here and there. Everything has gone well for the last
half-dozen modifications until last night. The latest one goes into the
AutoGem sequence and loops at the "Creating Solid Elements". Attached
is from the .stt after msengine crashed last night...As you can see the
% complete goes up and down as it iterates as well as the # of elements.
Any suggestions?
Thank you.

There are C1 discon's and edge angles < 0, but I checked and all the
other models had the same issues.

Searching for existing solid elements inside the volume ...
Found 0 existing solid element(s) inside the volume.
Pre-processing boundary features ...
Optimizing boundary point locations ...
Detecting thin features on the volume ...
Pre-processing volume features ...
Creating solid elements ...
99.4% complete after 2.0 min (27063 elements).
96.9% complete after 4.0 min (14113 elements).
95.9% complete after 6.0 min (15428 elements).
94.7% complete after 8.0 min (16726 elements).
93.3% complete after 10.0 min (17892 elements).
97.0% complete after 12.0 min (14430 elements).
96.9% complete after 14.0 min (15575 elements).
95.1% complete after 16.0 min (16846 elements).
95.4% complete after 18.0 min (17603 elements).
92.9% complete after 20.0 min (18834 elements).
93.5% complete after 22.0 min (19471 elements).
94.2% complete after 24.0 min (19901 elements).
96.1% complete after 26.0 min (16129 elements).
95.1% complete after 28.0 min (17081 elements).
94.2% complete after 30.0 min (18327 elements).
94.8% complete after 32.0 min (18928 elements).
93.5% complete after 34.0 min (15784 elements).
93.3% complete after 36.0 min (16308 elements).
91.5% complete after 38.0 min (17401 elements).
92.5% complete after 40.0 min (18080 elements).
90.8% complete after 42.0 min (18885 elements).
90.2% complete after 44.0 min (19973 elements).
90.8% complete after 46.0 min (20448 elements).
93.1% complete after 48.0 min (18791 elements).
95.9% complete after 50.0 min (15730 elements).
94.5% complete after 52.0 min (16739 elements).
95.3% complete after 54.0 min (17578 elements).


--Scott


======
Scott Gold http://www.eone.com
<http: www.eone.com="/>
Product Development Engineer sgold@eone.com

Environment One Corporation Phone: 518-346-6161 (x3014)
2773 Balltown Road Fax: 518-346-6188
Niskayuna, NY 12309-1090 Email: sgold@eone.com
======

2 REPLIES 2

Re: Mechanica Loop

Scott,

The last change you made has caused a problem with the geometry. Most likely a sliver surface has been created. The thing you must do is modify the geometry to eliminate the problem.

WF 2.0 has been greatly improved in this area and will actually gloss over trouble areas (with your permission). You did not say what version you are using, but it would be rare for WF 2.0 to give you this type of problem.

First thing I would do is increase or decrease some radii slightly, and try again. If that doesn't work, then you might have to go ahead and try to find the problem area then make your geometry change according to what you discover. There are a couple of ways to do this.

One way is to take the model into Independent Mode and try a SHELL mesh. If successful, then turn the display of all shells off but leave the points displayed. Look for a glob of points (Yellow). Zoom in, and you will see the problem. If the shell mesh is not successful, it will most likely halt and tell you the "Highlighted Area" is causing a problem. At that point, you will have to pan and zoom around until you see a red curve. Sometimes these are hard to find.

After that, go back to ProE and fix the problem.

With Integrated Mode, it is more difficult to find these areas. You have to look around (in hidden line mode) carefully at your last feature for a tiny tiny sliver surface. Sometimes they are so small, that you have to really zoom up close and pan a lot. Use logic to understand where what you did would cause surfaces to intersect and/or overlap.

Randy Speed
President and CEO
Speed Consulting, LLC
(972) 938-0490 ph (972) 937-2319 fax
www.speedconsulting.com

Re: Mechanica Loop

In integated mode, a mesh button exists that runs the mesher with only
material properties needed. It's set to do solid elements by default. It
does not invoke the solver.

Now in this mesh you will see highlighed areas where difficulty occurs.
Those will be your areas of focus back in Pro/E, yes as Randy says, likely
slivers.

Marty