cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Black Background in IsoDraw 7.2 M030

Highlighted
Level 1

Black Background in IsoDraw 7.2 M030

Good day all,

I think there is a bug in IsoDraw that causes the background color to switch back and forth between black and white. I have a new Windows 7 laptop, and now I get a black background when I open CGMs.

The backgrond always changes to white at about 20% zoom level. It also changes to white when I zoom in more than 100%, but at totally random zoom levels that change when I pan to different parts of the graphic.

I can't find a setting in preferences that makes a difference. I have searched all over for posts on this problem, but I have not seen a solution yet. I can't see black text in my callouts without zooming in and out all the time. It's annoying!

Has anyone else had this problem and found a fix?

-Renee

Tags (1)
3 REPLIES 3

Re: Black Background in IsoDraw 7.2 M030

Did you try to close "OpenGL"? Sometimes that helps ...

Re: Black Background in IsoDraw 7.2 M030

Hi Renee,

We had this exact same issue here at GA. We came up with a fix and discussed it on the IsoDraw Users Group in LinkedIn. Heres what we found out:

Description:

CGM graphics viewed in Internet Explorer using IsoView display as white graphics against a black background. This happens in NSIV and when CGMs are viewed from the CSDB.

Resolution:

Navigate to the following location: C:\Users\<user id>\AppData\Roaming\PTC\IsoDraw\Preferences

If the AppData folder is not visible, the folder options to view hidden folders/files must be set. See process at bottom entitled “View Hidden Folders”

Locate the file IsoView 7.2 Preferences.prf or IsoView 7.1 Preferences.prf. If you have both files the following process will need to be applied to both files.

Right click on the IsoView preference file (IsoView 7.2 Preferences.prf/IsoView 7.1 Preferences.prf). Select “Open With”, “WordPad”. If WordPad is not available as an option, select “Choose default program…” The “Open With” window opens, select the “Browse” button. Navigate to C:\Program Files\Windows NT\Accessories\wordpad.exe. WordPad is now set in the Open With window. Select “OK”.

The preference file opens in WordPad. Scroll down to the text line “Use OpenGL for 2D: 1”. Edit this line by changing the one to a zero. The line then reads “Use OpenGL for 2D: 0”.

Save and close.

Restart the computer.

View Hidden Folders:

To view hidden folders, select “Start” in the lower left corner. Start menu opens.

Select “Control Panel” on right side of start menu. Control Panel window opens.

Select “Appearance and Personalization”. “Appearance and Personalization” window opens.

Locate the “Folder Options” category, and select the subcategory “Show hidden files and folders”. The “Folder Options” window opens.

Select “Show hidden files, folders, and drives”, select “Reset Folders” button, select “Apply” button, select “OK” button.

Close the “Appearance and Personalization” window.

Hope this helps.

Randall R. Jahn

Tech Illustration/Animation Supervisor

General Atomics EMS

Re: Black Background in IsoDraw 7.2 M030

Hello Randall,

I think the issue you addressed is different from the issue I am having. I am getting a black background in IsoDraw, but having no problems in IsoView.

I just discovered that the callouts seem to be causing my problem. It's not specific to any file format; I get the black background when I open any file that has callouts. Then as soon as I delete the callouts, the problem goes away instantly.

I can take one more look at the settings for the callouts, but this does not seem like normal behavior for any graphics tool. So, unless anyone knows of anything else to try, I might have to contact PTC about this one.

Thanks anyway for the response.

-Renee