cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot change K-Factor

SOLVED
Newbie

Cannot change K-Factor

Hi,

In WF5 sheet metal, when I try to change k-factor or y-factor (Edit>setup>bend allow>...) the k-factor and y-factor are greyed out. Nothing happens when I click on them. The only clickable option is bend table.

According to Help center it should be possible to change k and y-factor this way. Anyone that has seen a solution for this?

/Magnus

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cannot change K-Factor

Magnus,

Try to set sheetmetal parameter SMT_UPDATE_BEND_ALLOW_INFO to No.

By default the sheetmetal parameter SMT_UPDATE_BEND_ALLOW_INFO is set to Yes. This means the information is driven by the material definition (the Y factor can be changed within the material definition).

Good Luck

View solution in original post

3 REPLIES 3

Re: Cannot change K-Factor

Hi Magnus,

I just ran into this myself. After some investigation, I found out that sheetmetal parts that are converted from a solid have this issue. So this might be the case for you as well.

A workaround is to change the K-Factor for each bend feature. Tedious, but at least it can be done. It is evidently a software limitation that you can't change it for the whole part.

Re: Cannot change K-Factor

Magnus,

Try to set sheetmetal parameter SMT_UPDATE_BEND_ALLOW_INFO to No.

By default the sheetmetal parameter SMT_UPDATE_BEND_ALLOW_INFO is set to Yes. This means the information is driven by the material definition (the Y factor can be changed within the material definition).

Good Luck

View solution in original post

Re: Cannot change K-Factor

Thanks for the info, Mahesh, this definitely fixed the issue for me.

-marc