cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Select Feature Even Though it is on a Hidden Layer

Select Feature Even Though it is on a Hidden Layer

In many cases, the CAD operator will hide the layers containing Datum Axes, Datum Planes, etc. Whilst the layer is hidden, items on it are not available for use as references for other features, even though, by clicking on the item in the layer menu or the Model Tree, it will show up in red in the model window.

Idea:

Make it possible to use Hidden references for features, but only if they have been explicitly selected in either the model tree or the layer tree.

This could save a lot of time.

For example, I may want to place a hole on a datum plane and co-axial with a datum axis.

If my planes and axes are hidden, I must first unhide both layers, before I am able to use these references. This means that a great many Axes and Planes appear on the screen, so I either have to hide all the individual Axes and Planes except those I want, or query-select through until I find my targets.

If this idea were implemented, I could select the datums I wanted from Model Tree or Layer Tree, without having to unhide them, and without having to wade through the clutter on the screen.

Please vote up.

6 Comments
Topaz II

This is now possible, just not by clicking in the graphics area.  You can make selections in the model tree or by using the search tool.  I do this all the time, I'm not sure why it's not working for you.

Frankly, the point of layers is to turn these items off so they don't clutter the graphics area and having them 'selectable' there would defeat that purpose in my view.

Newbie

Doug, you are quite right! I must be havng a stupid day. I tried it again after you sent your message and, of course, it worked perfectly.

I really don't know what I was doing wrong - there really isn't ery much scope for error in such a simple process!

Cheers,

John

Regular Member

Have to try this again myself when I have ProE/Creo open.  Is it release specific?  In WF5 I seem to recall having this non selection if hidden problem myself but could have been how I was holding my toungue.  Will experiment.

Regards, Brent

Topaz II

I've never had an issue with it adn I've used layers extensively for many years.

Regular Member

If you are interested in this, you might want to vote for this as well;

https://community.ptc.com/t5/Creo-Parametric-Ideas/Hidden-by-Layer-should-be-hidden-in-Model-Tree-fo...

Community Manager
Status changed to: Archived