cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

2D Detailing: Embed Images in Drawings

RaphaelCNascime
1-Newbie

2D Detailing: Embed Images in Drawings

Attached to this blog post is a short presentation and a video on the new enhancement to allow direct embedding of images into drawings in Creo 4.0.

Any questions or feedback you have related to the ability to embed images in drawings should be provided as comments to the blog post.

That will be the easiest way for me to keep track of the comments and also be able to provide timely responses to your questions. If you follow this post, you can be notified of those comments as well and be able to learn from what others are asking. I may also periodically update this post to add some new details or information related to this enhancement.

Also, don't forget to follow the main blog post for 2D Detailing - which will have links to other 2D Detailing-related content 2D Detailing Home: Start Here!

Additional details on this enhancement:

  • By default, the image is not saved with the drawing file but will continue to appear as long as Creo can find the image file on disk. Since this Images tool in drawings is the same tool that is used in Part and Assembly mode it follows the same behavior as in those modes. There is a config.pro option "save_texture_with_model” that when set to YES will allow the image to be saved with the model. This option is currently not working for drawings in the Sneak Peek, but it will be fixed by the time we ship F000.

 

20 REPLIES 20

What about PDF?

pdf is not a supported format for the Images tool (in 2D or in 3D) in Creo 4.0.

The workaround would be to convert the particular sheet of the pdf that you want to embed into a supported format and then embed that object.

TomU
23-Emerald II
(To:RaphaelCNascime)

Will this image export correctly out to the derivative file types?  (DWG, DXF, PDF, etc.)  Will it show up correctly during publishing? (PVZ, HPGL [.plt], etc.)

When importing an image file and rotate it about 45 degree the print preview and output is not ok.

TomU
23-Emerald II
(To:RaphaelCNascime)

Raphael Nascimento‌, something is very, very wrong with the Postscript output of these images.

Print Preview (and also Save a Copy to PDF)

What the Postscript contains (both output from a color printer and converted to PDF)

TomU
23-Emerald II
(To:RaphaelCNascime)

There is also a problem with the images and the new "Auto Rotate" printing option.  The image is being rotated and/or resized.

How it's supposed to look:

How it looks with Auto Rotate on and selecting a different orientation:  (wrong size)

There is also some type of "modal" switch that gets flipped behind the scenes causing a similar issue with Save a Copy to PDF:  (rotated)

TomU
23-Emerald II
(To:RaphaelCNascime)

Same issue when exporting to DWG:

TomU
23-Emerald II
(To:RaphaelCNascime)

It would be nice to have a config option to set the initial (default) transparency level.  I would prefer 0% instead of 50% as the initial value.

I'll pass these issues along to the development team to get fixed.

Thanks!

Not a bad idea. I'm not sure if we can squeak that into F000, though...

Actually, I would prefer to just have it default to 0% transparency in drawings as the 80% use case and avoid the config. That'll probably be easier to do anyway.

TomU
23-Emerald II
(To:RaphaelCNascime)

Okay with me! 

How does one embed images into a drawing so there's no external references or links? When we add an image to drawings, Creo 4 M040 creates a link to user's computer location for the image. The link breaks when the drawings gets checked into Windchill because the file isn't found on the next person's computer. If it is possible to embed images, is there a way to make it the default? I assume most people would want to have images embed by default... imagine PowerPoint having external links to any images. Everyone would have broken PowerPoints all the time.

 

How to Embed Images into Drawings.jpg

I think I figured it out. The unintuitive setting save_texture_with_model yes seems to control this. Why this is defaulted to no? Seems like that is a recipe to break things all the time.

Thank you for your detail explaination about the 2D Detailing .

Has anyone managed to import an image and maintain decent resolution? Whatever I try, with different image formats and config options, I can never get a high-resolution image to be imported at same resolution in Creo. It always gives me a low-resolution version.

@Pettersson I got the same problem... Have you found a solution for the quality drop of the pictures when creating a pdf?

 

Many thanks!

 

Janik

Pettersson
13-Aquamarine
(To:JG_9456840)

Nope. Sorry.

Figured it out: drawing_ole_image_dpi is at 150 dpi default.

Change it to 600 dpi and you're good to go!

 

Janik

Pettersson
13-Aquamarine
(To:JG_9456840)

Really? I haven't seen that option before. I'll send that on (it wasn't me that had the problem in the first place). Many thanks!

 

EDIT: My bad, I can see that I had already suggested that, and apparently it didn't work. Thanks anyway!

Announcements