cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Anybody using Smart Assembly in Windows 10?

Highlighted
Moonstone

Anybody using Smart Assembly in Windows 10?

I am using Sigmaxim Smart Assembly in Windows 10. The problem is it running very slow. The same code working with Creo 2.0 in Windows 7.0 good. But comparatively it takes huge time to finish the job in Windows 10.

 

Any body can help on this?

9 REPLIES 9

Re: Anybody using Smart Assembly in Windows 10?

Most of my users are on Windows 10 now (my machine is still on Windows 7) and nobody has complained that things are slow/slower. Not that a lack of complaints means things aren't slower, but I usually hear about it if they are. We are on Creo 3.0 M100 and Smart Assembly 6.0 M040.

Re: Anybody using Smart Assembly in Windows 10?

We also have a mix of users on Windows 7 and 10 and I'm not aware of any run time difference between the two.  Have you done any troubleshooting to determine if it's a specific SA command that is causing an issue?  (You can output timestamps to help identify bottlenecks in the code...)

Re: Anybody using Smart Assembly in Windows 10?

Hi @TomU & @rcook

 Thank you for your valuable reply. Based on that I did following tests to identify the problems with Windows 10 OS

 

1. We have formatted our Windows 10 system and installed only Creo 2.0 & Smartassembly  - Result Failed

2. We have updated all graphics card drivers and tested - Result Failed

3. We have disable Intel integrated graphics and enabled nVidia graphics - Result Failed (Vice versa also Failed)

4. We have updated patch for SmartAssembly M60 version - Result Failed

Finally

5. We have uninstalled M60 version and installed M040 version - Result Success

 

 I have found the issue only in SmartAssembly 6.0 M060 Version with Windows 10. It working good in SmartAssembly M040 Version with Windows 10.

 

I have attached a sample sandbox application for testing. Can anybody test the application in both version (M040 & M 060) in Windows 10 and Let me know the status.

Right now I am working in M040 with Windows 10 version due to this slowness issue.

 

Note: Versions M060 working good with Windows 7 OS

Re: Anybody using Smart Assembly in Windows 10?

Sounds like you have it narrowed down. Is there functionality in M060 that you need? Or can you stay on M040?

 

Sorry, I am unable to help test right now. I have no bandwidth today and then I'm out of the office for a few weeks...

Re: Anybody using Smart Assembly in Windows 10?

I am seeing the same slowdown with SmartAssembly M060, but I'm seeing it on both Windows 7 and Windows 10.

Re: Anybody using Smart Assembly in Windows 10?

Hi @TomU / @rcook

 Right now I am using M040 with Windows 10.0 to avoid this slowness issue. However I raised this issue to Sigmaxim. One of my colleague using M060 with Windows 7 without any issues.

 

Re: Anybody using Smart Assembly in Windows 10?

I should clarify that I was testing in Creo Parametric 4.0 and 5.0.

SA060 Runtime.PNG

Note:  The large difference between operating systems is actually due to the computer hardware.  The Windows 10 machine is overclocked with solid state drives.  The Windows 7 machine in a very old laptop.

Re: Anybody using Smart Assembly in Windows 10?

It is not an issue with Windows 10. We had to make a change to the SmartAssembly environment to deal with a crash condition in Creo. The result was the need to scan through all the variables that are in memory at each line of the script to verify that the references being used are still valid.

 

That change was rolled out and presents itself as a speed issue under certain circumstances. While we can not revert back to the original code by default, we are releasing a new SmartAssembly config option that will allow you to set your environment back to the previous condition. Additionally, you will have the ability to trigger this mode on or off in individual applications to better control the crash conditions.

 

This will be rolled out in M070.

Re: Anybody using Smart Assembly in Windows 10?

Announcements