cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 3.0 JLink Issue

Level 4

Creo 3.0 JLink Issue

HI,

I have java application which is currently working in Creo 2.0. Yesterday we had installed Creo 3.0 and checked the application but it is throwing the below error:

Can not read params from db java.lang.SecurityException: Prohibited package name: java.util

 

I am using the below java version:

C:\>java -version
java version "1.8.0_151"
Java(TM) SE Runtime Environment (build 1.8.0_151-b12)
Java HotSpot(TM) Client VM (build 25.151-b12, mixed mode, sharing)

 

Thanks,

Dhimant

6 REPLIES 6

Re: Creo 3.0 JLink Issue

Hello @dbhensdadia

 

Check installation of default JRE in Creo 2 and Creo 3

JRE is installed at <Load point>\$PRO_MACHINE_TYPE\obj\JRE\

 

Check in config.pro option jlink_java_command. If you have this option, than Creo using external JRE. Try to comment this option.

Re: Creo 3.0 JLink Issue

This error is gone now I am getting the error while registering the jlink application.

 

Actually I have the existing jar file which is running fine without any error.

 

When I tried to rebuild the code inside the net beans and then if I am trying to use the update jar files I am getting the error: Startup of application "xxxx" failed.

 

I don't know why because the other old binary is running fine but updated one not.

 

Can you suggest me why it is so?

 

Thanks,

Dhimant

 

Re: Creo 3.0 JLink Issue

will creo work with java 9?

Re: Creo 3.0 JLink Issue

Hi @rmcboaty

 

Creo 3:

JDK 1.7.0_25

JRE 1.7.0_25 (on media)

JRE 1.8.0_40

 

Creo 4:

JDK 1.8

JRE 1.8

 

Re: Creo 3.0 JLink Issue

@dbhensdadia When you rebuild the code inside the net beans, ensure in NetBeans setting that you use JDK the same or lower then JRE. Look at next message in this theme.

Re: Creo 3.0 JLink Issue

Hi,

 

just FYI. Last week I created J-Link application for Creo 4.0. During my work I got error: Startup of application "xxxx" failed. The root of the problem was 32-bit Java 1.8.161 installation. When I installed 64-bit Java 1.8.161 the error was gone.

 

Note: I applied following command, too

set PRO_JAVA_COMMAND=C:\PROGRA~1\Java\jre1.8.0_161\bin\java.exe

 


Martin Hanák