Showing results for 
Search instead for 
Did you mean: 
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Did you know you can set a signature that will be added to all your posts? Set it here! X

Direct Modeling Express 4.0 and Windows 8.1


Direct Modeling Express 4.0 and Windows 8.1

Directo Modeling Express 4.0 worked fine on Windows 8. I updated my PC to Windows 8.1 and the only program DME 4.0 is the only program which doesn't work anymore.

When I launch it it briefly appear in the task manager, but crashes even before rhe splash screen.

Event viewer reports an application crash in Kernel32.dll (core Windows dss) called by SolidDesigner.exe

These are the details:

Faulting application name: SolidDesigner.exe, version:, time stamp: 0x4e74670d

Faulting module name: KERNEL32.DLL, version: 6.3.9600.16408, time stamp: 0x523d5199

Exception code: 0xc000041d

Fault offset: 0x0000000000001c90

Faulting process id: 0xf54

Faulting application start time: 0x01cecdba6a7c12af

Faulting application path: C:\Program Files\PTC\Creo Elements\Direct Modeling Express 4.0\binx64\SolidDesigner.exe

Faulting module path: C:\WINDOWS\system32\KERNEL32.DLL

Report Id: a9b7e300-39ad-11e3-beaa-c80aa964ff42

Faulting package full name:

Faulting package-relative application ID:

Anyone tried to run DME on Windows 8.1?


This thread is inactive and closed by the PTC Community Management Team. If you would like to provide a reply and re-open this thread, please notify the moderator and reference the thread. You may also use "Start a topic" button to ask a new question. Please be sure to include what version of the PTC product you are using so another community member knowledgeable about your version may be able to assist.

I forgot to mention that compatibility mode didn't help (neither Windows 8 nor Windows 7)

I have the exact same issue. After upgrading to Windows 8.1 Direct Mdeling Express fails to run. I however don't even get an error / crash dialog. Can we get a support statement from PTC on this?

There is no error message, the application fails before it can display the splash screen:the information in my first post come from the event viewer.

I have same issue on a Lenovo Yoga 13.

Hey Carlo - welcome to the PTC Community!

Regarding potential issues with Windows 8, please see the following discussion: New to Creo -- Elements Direct Modeling Express won't start after install

The PTC Creo Elements/Direct team is still in the testing phases with Windows 8.1 and were unable to provide any further information at this point. We'll be sure provide any updates that become available.

28 November 2013

Hi Ryan,

I have just downloaded this software and I run Windows 8.1, when will the team have the udate ready for the trial to run.

Top Tags