cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

We are working to address an issue with subscription email notifications. In the meantime, be sure to check your favorite boards for new topics.

FLEXLM - fixed license issues ...still

TomD.inPDX
17-Peridot

FLEXLM - fixed license issues ...still

Hi all. I need an IT guru to help me here.

 

Many moons ago, I created a tech support case for license issues regarding putting my computer to sleep and having the LM hang on me.

 

The solution was to install a very old version that was considered rock solid. And for the most part, it is.

 

However, when I put my computer to sleep, -sometimes- the license hangs and is invalid when the computer wakes up.

 

It is a c.r.a.p.-shoot and it is getting old. I have to put my computer to sleep from time to time and I need to be able to count on Creo booting when I wake it up.

 

DOES ANYONE KNOW HOW TO MANUALLY SHUT DOWN THE LICENSE SERVER SO IT WILL REBOOT WHEN NEEDED WITHOUT REBOOTING THE MACHINE?

license_server.PNG

 

A batch file solution would be EXCELLENT!

1 ACCEPTED SOLUTION

Accepted Solutions

Now I know... it took a few days for the problem to re-surface.

on Windows 7, 64bit:

Task Manager > Processes > check the "Show processes from all users"

Locate "lmgrd.exe *32" -right click- > End Process Tree

Go to Services tab- note "FLEXlm server for PTC" is now Stopped...

-right click "FLEXlm server for PTC" > Start Service

Note that this is a WF3 license server for a fixed license; your process may vary!

Thanks Jakub and Martin for the insight. I can certainly do this through the Task Manager where I am more comfortable messing with things (read: recoverable )

View solution in original post

12 REPLIES 12

hi Tom,

Have a look at the Services tab in Win 7. Click Start --> then click Run --> then type services.msc and confirm.

http://www.askvg.com/windows-7-services-that-can-be-safely-set-to-manual/

Thanks Jakub. I will try that next time. I know it will not let me disable the service from the task manager due to permission issues. I will see if making FLEXLM manual will force it to behave.

Hi Antonius,

Seems when your machine is in sleep mode network card owning the license host ID is getting inactive and on machine wakeup, service for license manager is not starting (as Network card was down).

You may try the below steps:

1. Select Start > Right Click on Computer > Manage

2. Double click on Device manager > Expand Network adapters

3. Select Appropriate network card in the list > Right Click > Properties

4. Select Power Management tab > Uncheck "Allow the computer to turn off this device to save power" > Ok > Close Device manager.

This will disabling the network card on sleep mode and when machine will wake up, service will start on own as network card will remain active.

I hope this will help.

The adapter is on the cable I connect with and it does not have the option to be turned off. It is always on.

Again, it does not always fail... it is annoyingly intermittent.

I think Jakub is on the right track.

Antonius,

I think license manager on your machine is represented by FLEXlm server for PTC service.

To stop the service, create batch file containing the following line:

net stop "FLEXlm server for PTC"

To start the service, create batch file containing the following line:

net start "FLEXlm server for PTC"

You have to launch both batch files using RMB and Run as administrator command.

Martin Hanak


Martin Hanák

Now I know... it took a few days for the problem to re-surface.

on Windows 7, 64bit:

Task Manager > Processes > check the "Show processes from all users"

Locate "lmgrd.exe *32" -right click- > End Process Tree

Go to Services tab- note "FLEXlm server for PTC" is now Stopped...

-right click "FLEXlm server for PTC" > Start Service

Note that this is a WF3 license server for a fixed license; your process may vary!

Thanks Jakub and Martin for the insight. I can certainly do this through the Task Manager where I am more comfortable messing with things (read: recoverable )

No problem. This is just basics. I mean you are just doing something in OS using GUI, which should be easy.

Now how to make a batch (*.bat) file for this kind of operation? Heh.

Btw, how about just right click "FLEXlm server for PTC" > Restart when you are in Services tab? Would that work?

I don't think you have to kill the process with task manager first, as long as it is an already registered service in the OS.

That's what's funny, Jakub.

I don't have access to stop the FLEXlm server from the Services tab but I can stop the Process and then I have restart authority in Services.

We all know how convoluted the Windows 7 is with permissions... and it all depends on the installer. I'm just glad I no longer have to reboot for a license failure because this Dell machine takes - f o r e v e r - to reboot.

Well, that's odd. Sounds like you are not an admin.

When you run the command window via Start --> Run --> typing "cmd" and Enter, does it say on the top of that window that you are running it as an admin?

bf43fd894ef5116ac6b2aa0455a8e0c017457d477b825dff24108771cc18b107_Admin_CMD.jpg

Also, are you able to access windows registry?

http://windowsitpro.com/windows-server/how-can-i-stop-and-start-services-command-line

I get the same response, but not the admin command prompt.

If I do something that requires admin privilages, it warns me and asks me if I want to proceed.

I know there is a special admin command prompt I can get too.

Ok, then I guess you have already resolved your issue to the point where you could be happy with it. I mean as long as you don't have reboot your machine then it's all fine.

Guess I better won't recommend you to turn of UAC, and dig into it further on your own.

You might just need an OS script for a non-admin user, and that's it.

Well, easier said than done.

Problem: - FlexLM Server "Hangs" on wake from sleep:

For a laptop which serves the license, after sleeping the server doesn't work.:

 

Best solution is to create a batch file that you can run.  For me on Windows 10, I created a batch file:

"Restartcreoserver.bat"  (Simply a text file ending in "bat", what ever name you want just with ".bat" on the end)

  

The contents of the batch file is shown below between the bars:

-------------

net stop lmadmin_ptc
net start lmadmin_ptc

-------------

To fix your "down server" right click on the batch file and "run as administrator".

For debugging purposes, If you add a 3d line with the text "pause" it will allow you to read the messages when running the batch file, and require your to "press any  key" to continue.  If you run the batch file without administrator privileges you'll see permission messages.

 

------------------

If you want this to be automatically fixed, then you'll need a bit more technical knowledge.

(1) Run task scheduler and create a task to perform when the computer sleeps

(2) "New task"  - select a wake from sleep trigger as follows:

2a- Under the general Tab.

   -Choose some name "restart_creo_server"

   - be sure to check "run with highest privileges"  

2b Under Trigger tab: 

     -)     Log     : System <---select

     -)    Source: Power-troubleshooter <----

     -)    Event ID: 1 <-------

     -)   Configure for "Delayed Task" of 30 seconds (to allow your computer to wake...may need 1 minute delay if your computer is slow waking. 

2c Under Actions Tab

     Create a new action, and pick the batch file you made above "Restartcreoserver.bat"

 

 

That should be it.... 

I attached a "bat" file but this system would only allow .log files....so rename accordingly..

 

 

Top Tags