cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

ProEngineerEnd() causes creo crash

Re: ProEngineerEnd() causes creo crash

correct.... You are right...I also thought for memory leak , but git confused with code I have... I removed entire code and only kept Proengineerend into user_initialize()...so, could not understand what could be issue for memory... ? Also this crash is observed randomly twice or thrice in five times application run.

Additionally, I tried to do asynchronous mode... My exe has two argument and those argument doesn't launch creo... I changed extern "c" user_initialize to int main and inside main, only two API Proengineerstart and Proengineerend are kept. Removed user_terminate also. But new exe could not be executed as it mentioned some error. Could not get when exe execute without error...? Could you please help me on this ?

And yes , appreciate your time and response on this issue. Many thanks...

Re: ProEngineerEnd() causes creo crash

You need to set PRO_COMM_MSG, please check for the correct name, without this you can’t start Creo. For your batch stuff a EventProcess call before or after each toolkit call should be enough.

Re: ProEngineerEnd() causes creo crash

 

Hello Ketan_Lalcheta,

 

If RPN's response answers your question, you could mark that post as an Accepted Solution. Doing this could greatly help other community members with the same question find their answer quickly. Thank you both your participation on the PTC Community!

Re: ProEngineerEnd() causes creo crash

I tried and it didn't work.... Frequency of crash got reduced but still I am able to observe crash issue...

Moreover I tried for config option something related to graphics, but that also does not help much.