cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Regeneration status ProSolidRegenerationstatusGet()

Participant

Regeneration status ProSolidRegenerationstatusGet()

How to capture regeneration status (Green-Fully generated, Yellow-Needs regeneration, Red-Failed Regeneration) using

ProSolidRegenerationstatusGet()

5 REPLIES 5

Re: Regeneration status ProSolidRegenerationstatusGet()

Object of ProSolidRegenerationStatus is enum and you will get this as return type from API "ProSolidRegenerationstatusGet"

 

typedef enum
{
PRO_SOLID_REGENERATED,
PRO_SOLID_NEEDS_REGENERATION,
PRO_SOLID_FAILED_REGENERATION,
PRO_SOLID_CONNECT_FAILED 
} ProSolidRegenerationStatus;

 

 

 

Highlighted

Re: Regeneration status ProSolidRegenerationstatusGet()

Hi,

thanks for the reply.

I have written code as below, where objAsmMdl read the assembly name.

after writing this code every time it shows status 2 as failed regeneration which is irrespecting to the regeneration status of the assembly. I mean if the assembly is fully generated than also the code give the value as 2.

 

Can you help in improving the code?

 

ProMdl objAsmMdl;

ProSolidRegenerationStatus regenStatus = PRO_SOLID_FAILED_REGENERATION;

status = ProSolidRegenerationstatusGet((ProSolid)objAsmMdl, &regenStatus);

if (status != PRO_TK_NO_ERROR)

 

{

 Log::WritetoLog("ITCPATPumpAutomationMain::Regeneration Status----->Failed to Regenerate",status,0);

return status;

 

}

 

Re: Regeneration status ProSolidRegenerationstatusGet()

Maybe I’m wrong, but for me you check only the status of your function call, and not the return value ‚regenStatus’ 

Re: Regeneration status ProSolidRegenerationstatusGet()

I have never faced issue for this API . It works as it should be. Do you mean to say that status of regeneration is PRO_SOLID_FAILED_REGENERATION when you say status as 2? It never says this status when model is already regenerated. In case of circular reference, status could be PRO_SOLID_NEEDS_REGENERATION, but definitely not PRO_SOLID_FAILED_REGENERATION if model is already regenerated. HIH Ketan

Re: Regeneration status ProSolidRegenerationstatusGet()

Issue is resolved now. Thanks for your response.

Announcements