cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need to share some code when posting a question or reply? Make sure to use the "Insert code sample" menu option. Learn more! X

pfcasyncmt.dll: Invalid access to memory location

BartoszDobrzele
1-Newbie

pfcasyncmt.dll: Invalid access to memory location

Hi,

 

I am trying to run a simple app in async mode.

I have 64bit machine (Windows 7)

 

>echo %PROCESSOR_ARCHITECTURE%
AMD64

 

My JVM seems to be 64bit

 

>java -version

 

And I point my PATH to

 

proeWildfire 5.0\x86e_win64\lib

 

When I try to run my app - it fails on

 

System.loadLibrary("pfcasyncmt");

 

Throwing

 

Exception in thread "main" java.lang.UnsatisfiedLinkError: proeWildfire 5.0\x86e_win64\lib\pfcasyncmt.dll: Invalid access to memory location

 

Any ideas?

 

Bartek

7 REPLIES 7

The Path seems to be ok - Are you using the correct jar file (pfcasync.jar and not pfc.jar) ?

This is how I invoke the app

java -cp "C:\Program Files\proeWildfire 5.0\text\java\pfcasync.jar;[CUT]\workspace\JLinkSandbox\bin;[CUT]\workspace\JLinkSandbox\lib\log4j-1.2.16.jar;[CUT]\workspace\JLinkSandbox\simple-asynch\src\main\resources" jlink.SimpleAsynch

Hello

The problem is the spaces in the Pro/E path. You should not install Pro/E using spaces in the path. Move the install into a directory path without spaces, example C:\ptc\proewildfire5. This should fix the issue.

Why are you using log4j? I would use a JAR file to start the project.

An example start up batch file is displayed below. Note: it is for a 32 bit system due to the paths.

REM ****************************************
REM SET PRO/ENGINEER PATH
REM ****************************************
set PROE_DIR=C:\PTC\proeWildfire5

REM ****************************************
REM SET J-LINK APPLACATION PATH
REM ****************************************
set JLinkApp_DIR= C:\EclipseProjects\Workspaces\JLinkProject\jar

REM ****************************************
REM SETTING J-LINK CLASS PATHS
REM ****************************************
set PATH=%PROE_DIR%\i486_nt\lib;%PATH%
set PRO_COMM_MSG_EXE=%PROE_DIR%\i486_nt\obj\pro_comm_msg.exe

REM ****************************************
REM CALL J-LINK APPLICATION
REM ****************************************
java -cp %PROE_DIR%\text\java\pfcasync.jar;app.jar com.felco.exampleapp.MyAsyncApp

Hi,

I do not think it i a "whitespace in a path" problem. If I change the name of the lib to load I get

Exception in thread "main" java.lang.UnsatisfiedLinkError: no pfasyncmt in java.library.path

So the runtime is able to loacte the DLL. I have reinstalled ProE just in case but the problem remains.

Exception in thread "main" java.lang.UnsatisfiedLinkError: C:\Applications\ProE\x86e_win64\lib\pfcasyncmt.dll: Invalid access to memory location

Bartek

I had same issue...when I tried to run 64Bit ProE on 32Bit JVM....

may be this can hel u verifying JRE

http://java.com/en/download/testjava.jsp

I will give a bad suggestion...since system is having hard time in finding the "pfcasyncmt.dll".........

copy and paste it to the bin directory or to the class path...

and forgive me if something goes bad....just delete the newly copied "pfcasyncmt.dll"

upgrade from M010 to M060 fixed the problem

M010 seemed to have a bug

Top Tags