cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Distorted/warped geometry when exporting to step file.

SOLVED
Highlighted
Regular Member

Distorted/warped geometry when exporting to step file.

Hello all,

 

I am having difficulty exporting a particular part that I am working on to a step file.

 

The part itself is a tubular extrusion of quite a small profile (OD:2.2mm ID:1.8mm) over a relatively long length (2500mm), the part also features a very fine helical cut which runs the bulk of the length of the tube. I have adjusted the accuracy to "Relative 1.0e-04" (that's as fine as I can make it) in model properties given the fine details.  When in Creo all looks as intended (see below, the helical cut adds considerably to the regen. time but this I can deal with.

 

3.JPG

2.JPG

1.JPG

What is problematic is when I export this part to a step file. The geometry appears more like a surface than a solid has some pretty horrible warping running the length of the tube (See below). Ultimately I need to transfer this part to a third party for review and this issue will have to be rectified prior to this transfer, I'm just wondering if anyone else has encountered this problem?

Step_Export_2.JPG

Step_Export_1.JPG

Step_Export_3.JPG

   

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Distorted/warped geometry when exporting to step file.

I think you are battling two issues:

 

1. Part accuracy:  Relative accuracy changes the accuracy based on the size of the model.  As the model gets bigger, the accuracy gets lower.  Change your part accuracy to Absolute 1.0e-04.  You may have to change the config option enable_absolute_accuracy to yes.

 

2. Import settings: Default import settings include Simplify surfaces.  To check STEP file, start a new part and set the accuracy to Absolute 1.0e-04.  Import the step file and select details for the import profile.  Under the Surface tab, deselect Simplify surfaces.

 

I don't know how the CAD program of your third party will handle the STEP file.  A good screen shot of the geometry for the third party to use to verify the import would be recommended.


Creo is an endless adventure: Always more to learn.

View solution in original post

4 REPLIES 4
Highlighted

Re: Distorted/warped geometry when exporting to step file.

I think you are battling two issues:

 

1. Part accuracy:  Relative accuracy changes the accuracy based on the size of the model.  As the model gets bigger, the accuracy gets lower.  Change your part accuracy to Absolute 1.0e-04.  You may have to change the config option enable_absolute_accuracy to yes.

 

2. Import settings: Default import settings include Simplify surfaces.  To check STEP file, start a new part and set the accuracy to Absolute 1.0e-04.  Import the step file and select details for the import profile.  Under the Surface tab, deselect Simplify surfaces.

 

I don't know how the CAD program of your third party will handle the STEP file.  A good screen shot of the geometry for the third party to use to verify the import would be recommended.


Creo is an endless adventure: Always more to learn.

View solution in original post

Highlighted

Re: Distorted/warped geometry when exporting to step file.

Thanks for this, when I changed part accuracy to absolute, I was not able to go below "0.0072", therefore Absolute 1.0e-04 was not possible and the lowest on the possible range did not permit a satisfactory level of detail. Incidentally is there a way to increase the range of accuracy?

 

The import setting adjustment however seemed to do the trick, as you say I will just have to make sure that what the third party imports is as the design intended. Thank you again.

Highlighted

Re: Distorted/warped geometry when exporting to step file.

Use these config.pro settings:

 

enable_absolute_accuracy yes
accuracy_lower_bound 0.0001

Highlighted

Re: Distorted/warped geometry when exporting to step file.

There's one more:

default_abs_accuracy 0.0001

Usually the restriction I see when I'm trying to change accuracy from relative to absolute is if a model is kind of old and/or poorly defined. As I make the absolute accuracy smaller it will suddenly trigger a bunch of failed features. That's when the detective work starts...

Announcements