cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How do you prevent the display from resizing when regenerating an assembly?

Highlighted
Newbie

How do you prevent the display from resizing when regenerating an assembly?

WF 2.0

I have an assembly that moves throughout a range of motion via a skeleton part with a program driving it. Every time I regenerate the assembly (and hence the skeleton part) the assembly moves one more step throughout its range of motion.

The issue I am having is that every time I regenerate the assembly, the view display "resizes" to fit the assembly to the screen the way it sees fit. I do not want this because in this case I want to save the screen shots as jpgs for an animation. When the display regenerates, I end up with components that should be fixed getting slightly smaller and then larger again as the display resizes.

Is there a config option to prevent the screen from resizing slightly every time I regenerate the assembly?

TIA
Paul
1 REPLY 1

RE: How do you prevent the display from resizing when regenerating an assembly?

-----Original Message-----
From: -
On Behalf Of
paul@3dengineeringllc.com
Sent: Tuesday, June 27, 2006 9:57 AM
To: PTC/USER Model Discussion
Subject: [model] How do you prevent the display from resizing when
regenerating an assembly?



WF 2.0



I have an assembly that moves throughout a range of motion via a skeleton
part with a program driving it. Every time I regenerate the assembly (and
hence the skeleton part) the assembly moves one more step throughout its
range of motion.



The issue I am having is that every time I regenerate the assembly, the view
display "resizes" to fit the assembly to the screen the way it sees fit. I
do not want this because in this case I want to save the screen shots as
jpgs for an animation. When the display regenerates, I end up with
components that should be fixed getting slightly smaller and then larger
again as the display resizes.



Is there a config option to prevent the screen from resizing slightly every
time I regenerate the assembly?



TIA

Paul



----------------------------------------------------------------------------
----------------------------------------------------------------------------
-----------------------------------------------------

The solution was to create a sketched datum curve (I used a square)
significantly larger than the overall assembly. Place the curve on a layer
and blank the layer.

Since the datum curve is significantly larger than the assembly, the
assembly now stays in one "place" when regenerating.

Thanks to Kevin, Marc, Robert and Bill. You guys are the greatest!



Paul