cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

IGES Import

Highlighted
Participant

IGES Import

Hello,

 I am currently using Creo 5.0.4.0

Users at my company have been through many Creo related changes in the last year or so.

These changes include version upgrades and configurations

Prior to these changes I was able to import IGES data and select flat surfaces on the data for sketching,

extruding etc.

I can no longer do this. Can anyone explain why?

 

Thank You

10 REPLIES 10
Highlighted

Re: IGES Import

@bparker

 

This seems to be sue to surface quality, if in case imported surface is not planer, it cannot use for operations as extrude and all... 

It will  be a good option to confirm about surface quality and I think it will specific top data set or possibly to specific to surface in imported data. Which Creo version are you working with? 

Highlighted

Re: IGES Import

Thank you MaheshSh.

I am working with Creo 5.0.4.0

I could understand the surface quality if the data was coming from another software.

In my situation, it occurs with data from all sources including my own session of Creo.

If I export data out and bring it back in immediately I am unable to utilize the "flat" surfaces.

This is true for surfaces that have been created as using "FILL" and "EXTRUDE".

I believe that the .stp format does not have this issue - only .iges. It seems like the .iges

format itself has changed.

 

Highlighted

Re: IGES Import

@bparker

I tried the same but working for me.... 

Can you create a sample file and iges for the same?

Highlighted

Re: IGES Import

Thank you MaheshSh.

Please see the attached file.

Highlighted

Re: IGES Import

It is working for me, imported file (without template) in Creo 5.0. Created an extrude referring one of the surface in imported data.

Check attached video, am i missing something in that? 

Highlighted

Re: IGES Import

Thank you.

Your video describes the process correctly.

Your help is appreciated very much. I will continue to

look for a solution .

 

With Best Regards,

Barry Parker

Highlighted

Re: IGES Import

@bparker

 

Try with default Creo session i.e. without Windchill (if using)/config.pro/config.sup... 

Or try in Creo 5.0.5.0 on one of the machines. 

Highlighted

Re: IGES Import

I just launched Creo without Windchill and without any configuration mods (blank config.pro).

The same issue persists with the sample file and with a new file created through the default session.

 

Maybe there is a template issue?

 

Thank you

Highlighted

Re: IGES Import

yes, may be template...

 

When importing Iges, uncheck "Use template" (if checked) and try. 

 

Still if it reproducible, you may contact PTC Technical support. 

Highlighted

Re: IGES Import

Thank you for your help MaheshSh.

Unfortunately, it is the same even without the template.

I will try PTC Technical support as you have suggested.

 

Regards,

 

Barry Parker

Announcements