cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

CREO Assigning colours to wires and cables

Highlighted

CREO Assigning colours to wires and cables

What I would like to do is have the colours of wires represent the colour of the spool from which that wire is drawn. Now whilst I accept that the wire colour parameter is just a label that can be used in reports and is in no way linked to a colour in the rendering sense I would like to know if there is any way of assigning a visual colour to a spool.

Alternatively.

In WF3 I could colourise a harness by applying colours to individual wires but in CREO I can not find how to do this. The wires are created in a default colour and any attempt to colour a wire selects the whole harness. The 'new' process of selecting the object to which the action is to be applied before the action you wish to perform, does not work in this case. I select an individual wire then select the colour I wish to apply but the selection dialogue does not appear and I can't OK the process for the colour to be applied. If I can't colourise a spool how do I colourise an individual wire?

12 REPLIES 12
Highlighted

Re: CREO Assigning colours to wires and cables

Hi Colin,

In Creo you have wire parameter called colour with which you can assign colour.

Video Link : 2955

Highlighted

Re: CREO Assigning colours to wires and cables

Thankyou. That is how I was hoping it might now work as in previous versions of WF that parameter had no visual bearing on the model. However for me it still appears not to work in Creo. I have followed the same processes as you demonstrated in your video and the wires still appear in the default part grey colour.

Additionally from where are those visual colours being obtained and how would I add to the list of possabilities as one colour which is missing that we use a lot of is pink!

Highlighted

Re: CREO Assigning colours to wires and cables

It worked in WF5 i belive. You just needed to write name of appearance. Example if in you default appearance file was "BLUE" you write it in colour parameter and cable/wire take apearance from it. You could make "pink" and use it no problem , just save your apearance file with that new colour.

Highlighted

Re: CREO Assigning colours to wires and cables

Hi Colin...

Don't be fooled by the drop-down menu in the spool tool. You can add ANY color to your wire spool. As Davor said, as long as you've named the color in your appearance palette, you can use it to color your wires

I seemed to recall a reported bug in either WF5 or Creo regarding the color of cables. I don't recall what the error was or if it's been fixed. I just tried assigning colors to my spools in Creo and it worked perfectly. Do you have any files we can take a look at? Maybe it's just something simple?

Thanks!

-Brian

Highlighted

Re: CREO Assigning colours to wires and cables

I just figured it out! This has been bugging me off and on since we switched from WF4 to Creo 3.0 June 1st last year.  We typically use just white wire in our physical assemblies but the Manufacturing Engineers and assembly people like to see colors in in the models to help visualize the from to flow better when we start with 6 switches  and exit to 3 connectors.

The secret is to be in the thin wire display.  Pick once on the wire segment you want to color, then move the mouse slightly to a different point on the same segment to select the whole wire.  Once the whole wire is selected, apply the color you want with the "Appearance Gallery" button or use the drop down under it and scroll down to the color in your gallery you want to apply.

Highlighted

Re: CREO Assigning colours to wires and cables

Hi Brian,

That seems to be the hard way to do it. Creo is capable of auto assigning the colors based off the parameter in your spools.

1. Change the names of the colors in "My Appearances" from the Appearance Manager in the Appearance Gallery so that they match how you want to reference each color. (WHITE,WHT, vs WT for example or BLUE, BLU, vs BU).

2. Change the COLOR parameter in your spools to the designated name for that color.(WHITE, WHT, or WT. It is not limited to the colors in the drop down.)

3. Regenerate the wiring and all the colors should appear for every cable based on how they are defined in the appearance manager.

I think we had an issue with the letter cases when defining all these. We use capital letters in the Spool parameter and lower case in the Appearance Manager and that seems to work.

Highlighted

Re: CREO Assigning colours to wires and cables

It is the hard way unless you use all white wires but the new product manufacturing engineers like to see different colors for different sub connector in the bundles.  We use the color parameter and the color named the same when we use colored wires but I can't use a different spool just to have the color show up different.  That will throw off our from-to cabling tables that have the spool ID in them.

My previous reply was directed toward being able to directly apply a color (American spelling) to an individual wire and maintain the integrity of the cable bundle data when it goes to a harness house.

Brian H

Highlighted

Re: CREO Assigning colours to wires and cables

Oh I see. Sorry I misunderstood your situation.

In that case there are a few different ways to accomplish that. Essentially you have to select the Cable/Wire instance of the geometry not the segment which is normally the piece that gets selected first when clicking the geometry.

The best way if you have to change multiple wires would be to select the wires from the model tree that you need to change. Just make sure to select the wires not the segments. This way you can do multiple at a time relatively easily without having to carefully select the thin line reps in the geometry.

You can also accomplish this with the search tool while in the cabling application. Use cntrl+f to open the menu and then change the Look For value to Cable. It can search and select all the cable elements in your file(Wires, Cables, Bundles).

Edit: After selecting the wires use your method in the appearance gallery to apply the desired color.

Highlighted

Re: CREO Assigning colours to wires and cables

Hi to all,

someone can confirm that at the moment it isn't possible to apply a texture or a decal to a wire?

Thanks.

Highlighted

Re: CREO Assigning colours to wires and cables

Hi,

 

I can confirm it. Only plain colors are applicable.


Martin Hanák
Highlighted

Re: CREO Assigning colours to wires and cables

I was also searching to add a decal (seems not possible on 4.0) but I was really happy to discover that we can now add stripes (on 5.0) !!
https://www.youtube.com/watch?time_continue=14&v=qmb8moTpREY

-----------------------------------
Pierre, expert on Solidworks ... losted on Creo
Highlighted

Re: CREO Assigning colours to wires and cables

You may as well select the cable from the model tree, then apply a color with the "Appearance Gallery" as you described.

Announcements