cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Cosmetic Sketch

SOLVED

Cosmetic Sketch

Hello Creo people

I created couple of cosmetic sketches to show paint masking area on my solid part.

In my drawing of that part, I can see those sketches only on my ISO view, but not on front or any other projected views.

Any idea how to make cosmetic sketches visible? How to control it?

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cosmetic Sketch

Hello! from your descriptions, you seem to say that your work and home setup produce different results - namely that at home, your sketch is not shown in the section view (screenshot) while at work it is shown.  So I investigated some things in my setup (Creo 3.0 M130)


So for your second Q, this drawing option seems promising:

remove_cosms_from_xsecs

(in drawing mode, file->prepare->drawing properties->detail options (change)->find->(search descriptions)->type keyword "cosm"->find now)

If set to "trim", then system removes from display the portion of datum curves and cosmetic features that is in front of section cutting plane.

If set to "total" (default), then only things entirely in front of the cutting plane will be removed from view...

Now the long winded answer to your first Q:

So cosmetic sketches are a bit of an oddball and perhaps it is wise to avoid them.  They are very handy when you are dealing with non-parametric things such as logos and labels that contain a lot of entities because you can use the "under-constrained" mode and essentially doodle something without the system crawling to a stop trying to solve all the sketcher constraints!

And another thing I learned during this investigation, is that cosmetic sketches they are drawn on a plane that is orthogonal to the view plane will not be shown in that view.  This answers why your cosmetic sketches are not showing up on any orthogonal projection views.

You can tilt the sketch plane about 0.1degrees and get a decent looking result.  But why use such a hack when a regular sketch can suffice?

One more thing about cosmetic sketches - you can right-click on a view and "erase/show cosmetics".  So that's one way to control the visibility of cosmetic sketches and so that can be an answer to your first Q.  Unfortunately, that is not a great solution if you have threaded holes and you do want the cosmetic threads to stay shown in the view!

So the "proper" method already mentioned in this thread is to put your sketches or cosmetic sketches on layers that can be blanked or shown on a per-view basis.

Layers are not easily explained, so if you don't know what I'm saying, you need to invest some time learning by reading these forums (just search for "layer" and go through the found discussions) and other online help (just google "creo layers")

11 REPLIES 11

Re: Cosmetic Sketch

Hi Eugene.

I used to use this many years ago for exactly your purpose but became frustrated with Cosmetic Sketch functionality where this type of sketch would show through parts which was not the functionality I wanted.

I changed to using the Datum Sketch feature which I found to be robust.  In Creo this is in the Model tab and the Datum subsection. It shows a Sketch in the Menu Bar by default.  [Note; This is the same Sketch functionality you would use for an external or embedded sketch].

Once you use this type of sketch then you can control how it displays in the model with Layers.  If you view the model with no hidden lines (or shaded) then you will not see the Datum Sketch if it is obscured by geometry (as you would expect). 

You can also use this same Layer control in the drawing including restricting the showing of the Datum Sketch to individual views if you want.  This assumes you display your part/assembly in the drawing with no hidden lines.

Hope this helps.

Regards. Brent

Re: Cosmetic Sketch

Hi,

please attach picture showing your problem. Also upload testing model+drawing (How to Attach a File to a Discussion Reply).

MH


Martin Hanák

Re: Cosmetic Sketch

Untitled.jpg

So brown line is a sketch and blue is a cosmetic sketch. Both are seen on ISO view and only sketch and not a cosmetics on a projection view.

First Q : is it possible to control cosmetics in my case to be seen or not.

Second Q. The reason I used cosmetics is that when I used regular sketch it was not sectioned on my x-section top view (at work and I am showing home version) and sketch was seen on x section view. What controls that? I tried different settings for the view and did not get needed result (sketch not seen).

Thanks

Re: Cosmetic Sketch

Hello! from your descriptions, you seem to say that your work and home setup produce different results - namely that at home, your sketch is not shown in the section view (screenshot) while at work it is shown.  So I investigated some things in my setup (Creo 3.0 M130)


So for your second Q, this drawing option seems promising:

remove_cosms_from_xsecs

(in drawing mode, file->prepare->drawing properties->detail options (change)->find->(search descriptions)->type keyword "cosm"->find now)

If set to "trim", then system removes from display the portion of datum curves and cosmetic features that is in front of section cutting plane.

If set to "total" (default), then only things entirely in front of the cutting plane will be removed from view...

Now the long winded answer to your first Q:

So cosmetic sketches are a bit of an oddball and perhaps it is wise to avoid them.  They are very handy when you are dealing with non-parametric things such as logos and labels that contain a lot of entities because you can use the "under-constrained" mode and essentially doodle something without the system crawling to a stop trying to solve all the sketcher constraints!

And another thing I learned during this investigation, is that cosmetic sketches they are drawn on a plane that is orthogonal to the view plane will not be shown in that view.  This answers why your cosmetic sketches are not showing up on any orthogonal projection views.

You can tilt the sketch plane about 0.1degrees and get a decent looking result.  But why use such a hack when a regular sketch can suffice?

One more thing about cosmetic sketches - you can right-click on a view and "erase/show cosmetics".  So that's one way to control the visibility of cosmetic sketches and so that can be an answer to your first Q.  Unfortunately, that is not a great solution if you have threaded holes and you do want the cosmetic threads to stay shown in the view!

So the "proper" method already mentioned in this thread is to put your sketches or cosmetic sketches on layers that can be blanked or shown on a per-view basis.

Layers are not easily explained, so if you don't know what I'm saying, you need to invest some time learning by reading these forums (just search for "layer" and go through the found discussions) and other online help (just google "creo layers")

Re: Cosmetic Sketch

Paul and Brent, thank you very much for you response.

It is definitely regular sketch that has to be used for purposes like mine and I apply your suggestion as soon as I will get to work WS.

Thanks again.

Re: Cosmetic Sketch

In case it hadn't been covered, you can turn off cosmetic features in views if you right click the view.

At the top of the list (IIRC) is the "erase cosmetics" option.

I use it to get rid of threads quickly for busy section views, but it should work for cosmetic sketches in any view.

Re: Cosmetic Sketch

So it looks like that a regular sketch will do the trick when curves put on a layer.

Can anybody tell me how to turn layers on and off in a particular drawing view? Somehow I was able to do it with 2 curves our of 4, but can not trace it back.

What layer will do it? Assy layers, Part layers, Drawing layers? I created my curves in ASSY.

Thanks

Re: Cosmetic Sketch

Open the layer tree in the drawing mode.  At the top, there is a selection box next to the arrow that allows you to manipulate the layer state for the drawing, model and any view.  Simply select a particular view to "set" the layer state for that view to be independent from the drawing.  In this independent drawing view layer state, blank the layer which contains the curves you want to hide.

You can click on the arrow next to the pull-down menu and by the color of the view outlines you will be able to tell what views have layer states that are driven by the drawing layer state and what ones are independent.

Further info in this forum by searching for "drawing layers".  E.g., How can I set the layer status for all drawing views

Re: Cosmetic Sketch

In short don't use cosmetics they are terrible.   A much better option is to use sketched datum curves.