cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 3, strange bug with draft dimensions not updating properly

SOLVED
Highlighted
Regular Member

Creo 3, strange bug with draft dimensions not updating properly

Hello! I'm looking for some help tracing down a really weird error; On a few of our template drawings, (drawings & models that we save-as from repeatedly), certain dimensions on the drawing don't update properly after the model is updated.

 

That is to say, we'll update the model and regenerate, then switch windows to the drawing and most of the dimensions will have already updated. However one or two will sometimes change to some garbage value, neither what the dimension was before nor what it should be now. A manual regenerate of the drawing will then update these wayward dimensions to the proper value. The problem is that most of the dimensions will update correctly leading the user to think the drawing is fully updated and ready to print without doing a regen of the drawing.

 

We are currently running the following config.pro options, which makes me think it’s not an issue that the drawing itself isn’t updating.

save_display no

auto_regen_views yes

I'm trying to figure out the root cause of this issue, and ideally there's some sort of config option to fix this... As it stands a small percentage of our thousands of template files seem to be affected. However I can't seem to figure out what the pattern is between the affected dimensions. on affected drawings, deleting and re-creating the dimension seems to fix this issue... However to go through all of our templates, and previous jobs that we save-as from would be tens of thousands of drawings to completely re-do the dimensioning to track down this weird little bug.

 

I've attached an example if you want to recreate the error. on first opening the drawing should look something like this:

 

error capture1.PNG

 

 

 

 

 

 

 

 

 

Then switch over to the top level assembly and change the overall length. That can most easily be done by changing the parameters QTY or DIA in the relations. Then regenerate the model to update it.

 

Then switch back to the drawing. All changed dimensions on the drawing should update automatically, except the overall length dimension will have updated to a junk value:

error capture2.PNG

 

 

 

 

 

 

 

 

Then regenerate the drawing, and the overall length dimension will update to the correct value:

error capture3.PNG

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly

I'm going to suggest you create a support case.  You have all the evidence you need to have a qualified tech explain exactly what is going on.  I've had good luck with this with PTC support regarding the functions under the hood.  If the reply is not satisfactory, you can escalate the case.

 

Obviously you are not seeing things and you also see what it takes to have a reliable drawing update.

PTC owes you an answer. 

Community members may know as well, but getting a clear understanding may need to come from the source.

View solution in original post

9 REPLIES 9
Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly

Sometimes references require a double regeneration.  Could this be your issue?

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly


@TomD.inPDX wrote:

Sometimes references require a double regeneration.  Could this be your issue?


Hey Tom,

I guess so... Regenerating twice does seem to make the dimension update to the correct value. The confusing thing though is the vast majority of the dimensions all update properly after one regeneration. So it's relatively easy to miss one dimension. Especially because this only seems to occur on a small subset of our drawings.

What makes a dimension require a double regeneration? Especially when the model is already fully regenerated before even going to the drawing?

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly

You have the opportunity to create associated dimensions to many things.

Just shy of a circular reference is the relation reference that updates and has another relation reference tied to it.

If you work a lot with relations, this is easy to do.

 

A relation reference as noted here is a value driven by relations.  Relations within a sketch are the likely culprit.  Moving these relations to the feature level may help.

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly


@TomD.inPDX wrote:

You have the opportunity to create associated dimensions to many things.

Just shy of a circular reference is the relation reference that updates and has another relation reference tied to it.

If you work a lot with relations, this is easy to do.

 

A relation reference as noted here is a value driven by relations.  Relations within a sketch are the likely culprit.  Moving these relations to the feature level may help.


This sounds like it may be our issue, we do have a great deal of relations in our models. Is there any way to see what a draft dimension is related to? Or is it just a bit of a crap shoot when you create a dimension what reference it will actually pick up?

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly

Creo is pretty good about selecting exactly what you want if it is valid.  You can even list it if you hold the right mouse button over your selection and select "pick from list".

 

Drafting dimensions are driven so they cannot cause a regeneration problem but could cause the delayed update.  Not something I was considering in the 1st reply.  Normally they just update on regeneration.

It is the driving dimensions of the model that I am giving greater weight to.  The actual updating of the 3D geometry would, ideally, update with a single regeneration command.

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly

Yeah for sure, ideally the models should update after one regen if all the relations have been ordered correctly... That's something I'm working on fixing on a number of our templates, but I don't think is the cause of my current issue.

Yes sorry I should have clarified, we use almost exclusively draft dimensions rather than shown model dimensions. While I personally prefer shown dimensions, that isn't the style at this establishment.

One interesting addition to the error, I just tried re-attaching the offending dimension to different geometry and it still wouldn't update along with all the other dimensions. This makes me think it has something to do with the dimension itself rather than the geometry it's attached to. Doing additional regenerations eventually makes the dimension take on the correct value... But again I'm trying to figure out why this particular draft dimension needs more regenerations.

 

error capture4.PNG 

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly

I'm going to suggest you create a support case.  You have all the evidence you need to have a qualified tech explain exactly what is going on.  I've had good luck with this with PTC support regarding the functions under the hood.  If the reply is not satisfactory, you can escalate the case.

 

Obviously you are not seeing things and you also see what it takes to have a reliable drawing update.

PTC owes you an answer. 

Community members may know as well, but getting a clear understanding may need to come from the source.

View solution in original post

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly


@TomD.inPDX wrote:

I'm going to suggest you create a support case.  You have all the evidence you need to have a qualified tech explain exactly what is going on.  I've had good luck with this with PTC support regarding the functions under the hood.  If the reply is not satisfactory, you can escalate the case.

 

Obviously you are not seeing things and you also see what it takes to have a reliable drawing update.

PTC owes you an answer. 

Community members may know as well, but getting a clear understanding may need to come from the source.


 


@dschenken wrote:

I second creating a support case. If this behavior was common it would have shown up already, or you are just the first of many. There may already be a fix which PTC has a related drawing update code for. It's entirely possible it's a combination of defects that only shows up in models/drawings built with a particular set of releases which is why it's not widespread.


 Sounds like I'll be talking to my support rep. Thank you both!

Highlighted

Re: Creo 3, strange bug with draft dimensions not updating properly

I second creating a support case. If this behavior was common it would have shown up already, or you are just the first of many. There may already be a fix which PTC has a related drawing update code for. It's entirely possible it's a combination of defects that only shows up in models/drawings built with a particular set of releases which is why it's not widespread.

Announcements