cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Drawing Layers not working and what does this mean?

Highlighted
Level 1

Drawing Layers not working and what does this mean?

Hi, I am using Creo 1 M40.

 

My drawing views are having issues with layers not working. I try and hide a layer and the features/curves do not hide. I have tried to associate the view with other views, 3D model, etc...but the layers/features will not hide as they should.

 

I did this "Check Display Status" and here is what it is telling me. What is this Recommended Action all about?

I have tried to use all the Update options in the menu ribbon as seen in the photo. Nothing has helped with the layers.

 

Anyone with the same issues and/or have some solutions for me?

 

Thanks,
Peter

 

views.JPG

Tags (4)
7 REPLIES 7

Re: Drawing Layers not working and what does this mean?

The "check display status" has to do with updating the drawing sheets or views, usually nothing to do with layers. We have our config.pro option "auto_regen_views" set to NO for performance purposes on large assemblies.

As far as layers go, make sure you don't have the view set so it has it's own layers. I usually do this by pushing the arrow next tot he model name in the layer tree and looking for views that have a green border (instead of blue). Those with green borders control their layers independently. Those with blue borders use the drawing layers.

layer.jpg

Re: Drawing Layers not working and what does this mean?

Seems I was really cryptic in my answer. The 'check display status' is usually model changes that don't show on the drawing views yet. You can update the drawing views or the sheet to fix those. You can also set auto_regen_views in your config options to YES (which is the default) and it should keep your drawing up to date but might give you performance issues with large assemblies or drawings.

Re: Drawing Layers not working and what does this mean?

There was a bug in Proe where some items that were turned off by layers show up again. This seemed to mostly affect curves and isometric views. The work around was to go to the layer dialog, then the tools menu (wrench & hammer icon) and select 'Drawing Layer Status'. You do not need to change any options, simply displaying the dialog would force the curves to display right.

This was in WF5 or maybe WF4. I'm not sure when it got fixed, it may still exist in Creo 1 Parametric.

--
Doug Schaefer | Engineering Manager
Crow Works

Re: Drawing Layers not working and what does this mean?

Thanks, but it doesn't seem to work! I was hopeful.

Re: Drawing Layers not working and what does this mean?

Thanks for the explaination. I didn't even notice the green vs blue borders. All my views are green and independant. I have tried to make dependent and then back to independant....nope.

Re: Drawing Layers not working and what does this mean?

My rule for view layers is to never use them unless I absolutely need that view to have different layer settings. If you have a drawing with 20 views and each view is independent, you have to "fix" the layers 20 times for that drawing.

Back to your problem, is this a new issue on this one drawing or is it now on all your drawings suddenly?

Re: Drawing Layers not working and what does this mean?

I feel this is sporadic with Creo. I feel yesterday my layers were fine and opened up the drawing today and they were funky. I just made all views dependent to the drawing, saved, and closed down. I opened up the drawing and made some drawing layer changes and that worked fine.

Then I wanted to make the view changes, to make specific layer tweaks, and as soon as I made one layer hidden it seems to have reverted back to the original independent layer status and things are fine. So, it seems like Creo keeps the view status even if you make the view dependent. Glad I got my views corrected, but not so happy Creo is doing things very mysteriously and I have wasted 2 hours on this. Come one PTC, layers should be the least of your issues.

Thanks again!