cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Entry Ports <absent>

Highlighted

Entry Ports <absent>

Hi, I am hoping someone has some insight here on entry_ports for cabling. I have certain shapes such as twinax, triax, and switches. My company likes to see the shcematic of switches esepcially in the wiring diagrams so that they can tell if the switch is normally open, closed, toggle, ect... I could not figure a way to make these shapes for a catalog as a variable group because of the limitation of one port per cell. As a result I made these shapes as blocks for the catalog. I apply my data set and it works great in Creo, reporting between the BID and WID.


The problem arrises when I export an xml file. When I export my xml file for Pro Cable, Pro Cable is unable to route the Block shapes because the entry_ports are <absent>.


My variable group shapes route, just not the Block Shapes. The difference is in the Data Sets I guess, the variable group shapes have member mapping???


I tried appling dt and mm files to the block shapes, however when applied it kept renaming the third port to BID. It did route though. So I am missing something. Switches as you know can have multiple poles and having it rename the third port to a BID port seems incorrect. What am I missing?


I saw a property called entry_port and tried to add this to the block shape ports but this did not work. Am I stuck making these shapes as Variable Groups with simple graphics? Please refer to images to see what shapes the engineers perfer.

1 REPLY 1
Highlighted

RE: Entry Ports <absent>

Jim, I added the parameter “Entry_port” to the “ports”, on my “block shape”, in our Central Catalog. I set that parameter to “ENTRY”, and that seems to have solved the problem.



The datasets for variable group shapes have member maps and data tables, and I am guessing, that the “Entry_Port”, parameter gets applied to the ports when the data set is selected. I was instructed for block shape data sets to export the csv file as a top sheet only, therefore, I am guessing again, that blocks do not have the mapping in the data sets that variable group data sets do? So I have to apply the “Entry_Port” parameter to the “ports” on the “block Shape” and set it to “Entry”?



Anyway that did work and the cable auto-routed with no errors.



Thank you for your help,



John

Announcements