cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Grouping in the model tree

SOLVED
Highlighted
Newbie

Grouping in the model tree

Grouping in the model tree.

I inherited a small assembly (about 100 items) from an employee who is no longer here, and ran into something that I, and a few others, have not seen before before.

When working in the assembly I grouped several fasteners together just to reduce my model tree, so I could correct some other issues.

After I got everything cleaned up (leaving the group in place) I started cleaning up the drawing and I noticed some rivets were missing in the views, not on the parts list.

I went back to the assembly and searched for the rivets and found that I had them grouped. When I highlighted on the group I could see the outline of the rivet, but it was invisible. These items were not hidden or suppressed, they were just grouped and invisible.

When I ungrouped, the rivets reappeared!

I grouped them back together and they were invisible again. The drawing parts list showed no change like suppressing an item. I was in "MASTER REP" when I did all of this grouping and un grouping.

I am on CREO 2.0 build M160. I then tried the same assembly on CREO 2.0 build M110 and got the same results.

I then opened an entirely different assembly, (one I worked on about a month ago), using (CREO 2.0 build M110) and I grouped some items in the assembly, and the items did not disappear.

No one here has seen this issue.

Has anyone seen this happen before?

Thanks in advance.

Tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Grouping in the model tree

You can unhide all layers temporarily to verify this idea.

MH


Martin Hanák

View solution in original post

6 REPLIES 6
Highlighted

Re: Grouping in the model tree

Is there a hidden rule based layer that looks for groups?

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Highlighted

Re: Grouping in the model tree

You can unhide all layers temporarily to verify this idea.

MH


Martin Hanák

View solution in original post

Highlighted

Re: Grouping in the model tree

Thank you Doug and Martin for responding.

Doug I am not sure where I would even find if there is a hidden rule for layers?

Martin I did unhide all of the layers and everything appeared! So I then looked a little further and it appears that it is in the "ALL_FEATURES" layer. So if I unhide that layer the grouped items are visible!

So that solved that problem.

I may be the only person that feels this way, but I really hate layers in CREO!

Thanks guys for your help.

DMT

Re: Grouping in the model tree

Debra,

rule based layer has special icon, see following picture:

layer_icon.png

Rule based layer definition is similar to following picture:

layer_properties.png

Automatic layer filling can be defined in config.pro file, too:

Look for DEF_LAYER option and ALL_FEATURES string (name of your layer).

MH


Martin Hanák
Highlighted

Re: Grouping in the model tree

There is a lot of things that you can do with layers, but I'd agree, thay are harder than tehy need to be.

I wrote a blog post some time ago about understanding layers, you can find it here:

Understanding Layers in Pro/ENGINEER - Design Central Inc.

The presentation that goes with it is available on Slide Share here:

Pro/ENGINEER Understanding Layers

--
Doug Schaefer | Experienced Mechanical Design Engineer
LinkedIn
Highlighted

Re: Grouping in the model tree

I agree with the answer you can unhide all layers, but that isn't helpful when you are trying hide other items on layers such as datum planes, axes, etc.

For an alternative solution I found a specific rule written in the default layer rules that when removed fixes this problem.  Select the layer that has the grouped components and click properties.  Then select the rules tab and click Edit Rules.  There is a rule in there "Type != Has Geometry (Category Miscellaneous)"  Select this layer (or a similar layer that value is "Has Geometry") and click Remove and click Ok.  Now then next time you go to group components in the assembly it will not put the group on the layer.  See the image below.


Layer Editor.PNG

Announcements