cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How to set up line thickness for drawings?

Highlighted
Newbie

How to set up line thickness for drawings?

Hi, when i used Inventor for modelling and drawings, the line thickness was set up for every kind of lines. Like outline was thicker than hidden lines or center lines. When i opened those exported dwg files in AutoCAD i could click on "show/hide line thickness" and outlines "poped up" from the drawing. Now - when i export drawings in Creo, all lines are same - hidden, outllines, center....How to set it up for all drawings? I mean - it should know what is model outline and what is just hidden line, right?

 

I hope you understood everything (my english is not so good as i want)

29 REPLIES 29

Re: How to set up line thickness for drawings?

Short answer - search for help on Pen Table and Drawing Line Weights

Longer answer - PTC hasn't been very good about line thickness for drawings. It is primitive, but adequate. Not as good as any other software I've used.

The main control is by line color mapping to pen number using a pen table. Each pen number can have a width associated with it. Geometry lines are assigned a color and hidden lines get a color; there are others. Part outline isn't an option. You can manually set line widths, but then you can't use a pen table, which would over-ride the widths you set.

Re: How to set up line thickness for drawings?

Creo 2.0 does have 3 basic line weights set up by default.

Maybe someone has changed your config.pro to use the same pens for all line types.

Re: How to set up line thickness for drawings?

I added my config.pro and pen_table_pdf.

It is set from my university, so i thought i would work. Can you find, where the problem is? Why are the lines all the same in dwg export?

Thank you

http://ulozto.cz/xERDw6u2/config-pro

http://ulozto.cz/xTLGvqrC/pen-table-pdf-pnt

Re: How to set up line thickness for drawings?

I did post reply yesterday with my config, but moderators doesnt want to accept it...so wait for it

Re: How to set up line thickness for drawings?

Moderation is usually because of including a hyperlink to a site that is not in communities.ptc.com; I am not certain if attachments are moderated.

Re: How to set up line thickness for drawings?

You are right...i did post it as a hyperlink. Here it is as attachement

Re: How to set up line thickness for drawings?

Maybe I am wrong but are you not telling the system you want all color 0,0,0 to be all 8 pens?

Try removing the color in the pen tables. Again, by default, entity types are assigned a pen.

This is what I use. I noted which pens are assigned to which feature. In reality, I only need 3 pens and set everything else very wide so I can easily tell if some new pen is assigned for some odd reason.

! DRAWING SETTINGS

pen 1 thickness .020 in

! solid edges

pen 2 thickness .008 in

! lettering

pen 3 thickness .012 in

! hidden and phantom

pen 4 thickness .1 in

pen 5 thickness .1 in

pen 6 thickness .1 in

pen 7 thickness .1 in

pen 8 thickness .1 in

Re: How to set up line thickness for drawings?

David,

I think (I am not sure) that an export to DXF/DWG is driven by dxf_export.pro file, only. This file is located in CR2_loadpoint\Creo 2.0\Common Files\M070\text\intf_configs directory. Also config.pro option INTF2D_IN_DXF_MAPPING_FILE can be used to specify a path to custom export file.

Martin Hanak


Martin Hanák

Re: How to set up line thickness for drawings?

Do notice that your pen 2 and pen 3 are the same thickness.... Where you duplicated 1-4 to 5-8, you have a different value for pen 7 (corresponding to pen 3).

pen 1 thickness 0.035 cm; color 0.0 0.0 0.0

pen 2 thickness 0.018 cm; color 0.0 0.0 0.0

pen 3 thickness 0.018 cm; color 0.0 0.0 0.0

pen 4 thickness 0.050 cm; color 0.0 0.0 0.0

pen 5 thickness 0.035 cm; color 0.0 0.0 0.0

pen 6 thickness 0.018 cm; color 0.0 0.0 0.0

pen 7 thickness 0.008 cm; color 0.0 0.0 0.0

pen 8 thickness 0.050 cm; color 0.0 0.0 0.0

The only way I can debug pen table issues is to name it table.pnt and place it in the working folder. You will have to remove assignments from config.pro to use this method.

The color assignment should be correct according to the help files. Are your lines coming out black for all the pens used?

Last question, what pen is assigned to your features? Are they still default or could they have been reassigned also? A simple test by making a pentable specific for this test should tell you this.