cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Limit dimensions unable to edit Tolerance limits

SOLVED
Highlighted
Newbie

Limit dimensions unable to edit Tolerance limits

Hi

I am having problems with limit dimensions I wish to be able to set upper and lower limits in the dimension but the option to allow me to edit this is greyed out.

I have taken the time to read a few posts so I know about changing

tol-display to yes in drawing options

I have also changed

Tools > options > tolerance_standard to ISO

I am just a bit lost where to go from here.

Thx.

Capture.JPGHope you can help.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Limit dimensions unable to edit Tolerance limits

I think that it is because it is an 'added' or 'driven' dimension, you should be able to enter the limts required in plus-minus mode and it will display correctly when you go to nominal.

If you use a 'shown' or 'driving' dimension you will be able to enter the limit tolerances directly.

If you are using limit tolerances you might also want to visit the config.pro option maintain_limit_tol_nominal - the default is no

View solution in original post

16 REPLIES 16
Highlighted

Re: Limit dimensions unable to edit Tolerance limits

I think that it is because it is an 'added' or 'driven' dimension, you should be able to enter the limts required in plus-minus mode and it will display correctly when you go to nominal.

If you use a 'shown' or 'driving' dimension you will be able to enter the limit tolerances directly.

If you are using limit tolerances you might also want to visit the config.pro option maintain_limit_tol_nominal - the default is no

View solution in original post

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Hello,

I think it comes from:

A) TOLERANCES_TABLE_DIR config options OR if you didn´t specify check

B) start parts

Check FILE - PREPARE - MODEL PROPERTIES - TOLERANCES (click on change) - popup menu apears - click TOL TABLES - MODIFY VALUE - GENERAL DIMMENSIONS

Here you can see and set table with generall tolerances (tolerances for unteleranted dimmensions), for shaft and holes...

In drawing mode try different TOLERANCES MODE (switch limits to plus/minus) - TOLERANCES TABLE = none, than you can write your own tolerance.

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Hi,

I've added several settings to my config.pro but I still have to go to Files->Prepare->Detail Properties->Details

and change "tol_display' to yes.

I've attached my config.

Could you take a look and let me know what I'm missing or not doing correctly?

I have tol_display yes and and the tolerance_table_dir set with directory location.

I have an inch and metric config. The inch is attached.

 

Thank you,

Jay Crook

Highlighted

Re: Limit dimensions unable to edit Tolerance limits


@jcrook wrote:

Hi,

I've added several settings to my config.pro but I still have to go to Files->Prepare->Detail Properties->Details

and change "tol_display' to yes.

I've attached my config.

Could you take a look and let me know what I'm missing or not doing correctly?

I have tol_display yes and and the tolerance_table_dir set with directory location.

I have an inch and metric config. The inch is attached.

 

Thank you,

Jay Crook


your config.pro doesn't control detail options. There is a "prodesign.dtl" file that Creo uses for drawings. The tolerance shown setting is in there.  You can save your modified "prodesign.dtl" file wherever your config says it is pulling it from, or you can save a separate one locally and load it when you start a new drawing.

 

Let me know if this helps or not.

 

Thanks,

Kenzi

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

I think that entries for directories that have spaces in them have to be enclosed in quotation marks.

 

tolerance_table_dir "C:\Program Files\PTC\Creo 4.0\M020\Common Files\tol_tables\iso"

Highlighted

Re: Limit dimensions unable to edit Tolerance limits


@dschenken wrote:

I think that entries for directories that have spaces in them have to be enclosed in quotation marks.

 

tolerance_table_dir "C:\Program Files\PTC\Creo 4.0\M020\Common Files\tol_tables\iso"


If you edit your config directly through creo, there is a browse option.  You have to select the file you want it to load.  You can also directly set the directory (folder) path of (for example) start parts or drawing formats this way.  I have never needed to manually type in a filepath, so I can't say whether or not you need the quotes around it at all. I have personally never had to, since i route through the "browse" function, then either copy and paste my filepath in, or manually go to the location I am seeking.

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Even I am having  the same issue. But, as you said i can't even my Tol_Tables option in model properties is grayed out. Please, help me finding a solution.

 

Thanks in advance

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Even I am having  the same issue. But, as you said i can't even my Tol_Tables option in model properties is grayed out. Please, help me finding a solution.

 

Thanks in advance

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Hi Karthik3,

Attached is a MS word doc explaining how I got the tolerance display to work in Creo 4.0.

If you have any more problems let me know.

 

Jay.

 

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Crook,

 

Thanks for the information. But my question was how do you edit limits? while working on it, I found the way to edit the value of limits. We need to go to plus-minus option in tolerance and give values. As I am new to creo, It's been a tough task for me.

 

Once again thanks for helping me out.

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Hi Karthik3,

I've updated the word doc I attached last night with the additional instructions.

 

Jay.

 

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Thanks for that.

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Hi Charlotte

Thx for you help it works with dims generated from Show model annotations but not with dim's added myself odd but this should allow me to complete my work Thx.

Last time I had a work mate who set this up for me I don't remember what he did last time, I was able to manual add a dim then change to limits then adjust the values I required.

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Hi all

I am really need to be able to edit limit tolerances on dimensions I have added hope you can help.

Thx.

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

Edit is using the "plus/minus" option, then switch it back to "limits".

It should display correctly.

 

IE:

Dim in CAD is 0.4, you need a limit of 0.394-0.400

Edit plus/minus +0.00, -0.006, switch back to limits.

Highlighted

Re: Limit dimensions unable to edit Tolerance limits

moved this discussion over to the Creo forum so that other may benefit.

Announcements