cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Show/Hide Cosmetic Feature

Highlighted
Newbie

Show/Hide Cosmetic Feature

How do I show a cosmetic sketch feature in a drawing view? I added a sketched feature to a model that already had an existing drawing with several views. When I switched from the model to the drawing I expected to see the cosmetic feature displayed in the appropriate views, however, it is not visible. Usually people inquire about hiding cosmetic feature, how do I show/display this feature?

10 REPLIES 10
Highlighted

Re: Show/Hide Cosmetic Feature

Did you check the layers status?

The layer in which your sketch is may be hidden?

Highlighted

Re: Show/Hide Cosmetic Feature

To resolve this I've tried the following so far w/o success:

1. checked the layer status

2. created a new view

3. tried to show/hide the cosmetic feature from the model

4. tried to show the feature via "annotations"

5. investigated the view properties "display options"

6. erased everything from memory and reloaded the drawing & part

7. relaunched ProE

8. created a new drawing

What I did discover is that when the part is displayed in the default "iso" orientation the cosmetic feature is visible, however, if it is displayed in a planar view it is not.

I'm still looking for a solution, so if anyone can help I'll be very appreciative

Highlighted

Re: Show/Hide Cosmetic Feature

I know that in 2000i, one could just hide the cosmetic feature and it would hide. I noticed that Creo 2.0 has totally messed up the simple classic dialog for this. You now have a lot things called Erase (which turns it off in the tree), Delete... which actually erases (hides again), and Remove... whatever that does. Someone at PTC is turning the basic computer literacy on its head by making such crude interpretations.

I had the same problem with sketches showing up. I hit so many buttons to get them to remain hidden, I forgot what I had to do to get there. I'm pretty sure I ended up taking care of the problem in the model. I'll see what I can do. What version are you using, David?

Highlighted

Re: Show/Hide Cosmetic Feature

I'm using Creo 1.0

Highlighted

Re: Show/Hide Cosmetic Feature

Have you talk to support about this? This poses a problem for me if the below discussion doesn't resolve this so please provide feedback. I do a lot of silkscreen work with cosmetic sketches. I use to be able to erase them easily with show/hide. Now that cosmetic sketch is no longer a "model annotation", this makes cosmetic (datum) curves a new issue to deal with.

Here is what I came up with. In the drawing, I created a layer called "HIDEME". I drag and drop the offending feature onto that layer. It shows up something like I posted below. You have to specifically change the feature to HIDE (right click and hide) rather than just the layer. I tried dropping it globally (onto the *.drw layer) but it wouldn't erase all the views.

Also notice the Layer Status Control dialog (from the layer tree Settings button, bottom line; drawing layer status) changes the way layers behave. You can have it follow the model but I believe the Ignore is the default.

I was hiding Curve_1 which is F46 in the drawing. Note that this is a layer in the individual view New_View_2. When I created the HIDEME layer globally in the *.DRW layer, it created one for every view.

I haven't yet gone back to start this exercise from scratch but I think you get the drift.

If you haven't yet started a case for this, I probably have to file one just to confirm this was the intended solution when they yanked cosmetics from the show/hide routine.

Can someone shime in as to how long the classic Show/Hide (with cosmetic feature) dialog has been removed?

This is Creo 2.0 Parametric

As for showing the feature, it is the exact opposite. I can turn the feature back on at will. I did add the feature after the drawing was set up and by default it showed in every view.

Hidding_Datum_Curves_in_drawings.JPG

Highlighted

Re: Show/Hide Cosmetic Feature

Antonius,

Unfortunately this didn't work. Also, I have not submitted a help desk ticket. Thanks for your support and please let me know if you come across anything else.

Highlighted

Re: Show/Hide Cosmetic Feature

Can you post the part and drawing files so I can have a look?

Highlighted

Re: Show/Hide Cosmetic Feature

I worked with this a little more last night. Indeed, the layers are tied to the whole drawing, not just the views as the dialog might imply. I was able to force features erased in the model to be displayed in the drawing, however.

There is a lot of counter-intuitive actions going on though... an "hidden" layer lets you "unhide" features under it. That's just wrong

Highlighted

Re: Show/Hide Cosmetic Feature

Right click on the view or the view name in the drawing tree and click "unerease cosmetic"

Highlighted

Re: Show/Hide Cosmetic Feature

Sorry Matt, does not work...

Announcements