cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Step files keep importing with "temp" part numbers

SOLVED
Highlighted
Guest

Step files keep importing with "temp" part numbers

So first I open an assembly from my company's windchill database, and generally the first thing I do after pulling a model is I export it to step file because the models directly from windchill have purple lines that ruin any "no hidden" line art I try to create for technical illustrations...that's another problem...moving on.

 

So after I've exported the assembly to a step file in the project folder, I try to go in and open it but instead of showing the part numbers in the model tree, every single part in the assembly has been replaced with a sequential nonsense number that is absolutely no help for working with the model. I've checked my export options, and I do not know how to fix this.

 

 

So far the only thing I've found is that the correct part numbers are now stored in the "layer names" column, but that is really inconvenient and I wish they'd just stick with the parts themselves in the hierarchy. Also, when opening the step file I see: "Processing __tmp__name__. Step 59: 100 percent completed" or something similar. It seems to be giving the parts "temporary" names. Why? I'm using Creo Parametric 2.0 on Windows 7 Enterprise.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Step files keep importing with "temp" part numbers

When windows are closed in Creo, the parts and assemblies aren't closed.  They remain "in session", meaning in memory just not displayed on screen.

What sounds like is happening is that you open the files from Windchill, export as a STEP file, close the window and then try to import the STEP file.  But, because you've only closed the window and not actually erased the files from memory, Creo cannot re-use the file names so it assigns new names.

That explains the original problem, why restarting Creo works and why re-opening the STEP file doesn't.

Try clearing the memory (File > Manage Session > Erase Not Displayed) to help your original problem. 

For re-opening the STEP file, try re-opening the actual assy from memory instead.  In the File Open dialog, look for "In Session" in the "Common Folders" list on the left.

--
Doug Schaefer | Engineering Manager
Crow Works
6 REPLIES 6

Re: Step files keep importing with "temp" part numbers

I see what you are asking for and I don't have an answer, but it really looks like you want a solution to a work-around instead of a solution to your real problem?

Why do you say your models directly from windchill have purple lines?  Purple lines normally mean you are dealing with surface models. I can help you turn the purple lines white if you like. Or maybe we change a few options to fix the no hidden line are you are trying to create.

Maybe I'm completely off-base, if so, please excuse my intrusion.

Stephen Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: Step files keep importing with "temp" part numbers

My company's Creo setup is managed at a global level and I cannot make the adjustments to those lines myself (the config files are, for the most part, locked). Additionally, the models are mostly locked and I do not have rights to go making changes just for my needs (I am a technical illustrator). So there is a bit more behind exporting to a step file, but currently that is the best workflow my department has. So I understand there are workarounds around this greater "problem", but this is not so much a problem to me as is my step files being messed up.

Re: Step files keep importing with "temp" part numbers

Could it be that it cannot create parts with those numbers because they already exist, so it pulls a numerical sequence of the next available numbers?

Re: Step files keep importing with "temp" part numbers

Oddly enough, if I restart Creo it will open the step file with the proper part numbers, so there may be something to what you say.

The interesting thing is that after I've opened the step file once, it won't open it again with the right part numbers....so is there any way to clear this "cache" without having to restart Creo?

Re: Step files keep importing with "temp" part numbers

When windows are closed in Creo, the parts and assemblies aren't closed.  They remain "in session", meaning in memory just not displayed on screen.

What sounds like is happening is that you open the files from Windchill, export as a STEP file, close the window and then try to import the STEP file.  But, because you've only closed the window and not actually erased the files from memory, Creo cannot re-use the file names so it assigns new names.

That explains the original problem, why restarting Creo works and why re-opening the STEP file doesn't.

Try clearing the memory (File > Manage Session > Erase Not Displayed) to help your original problem. 

For re-opening the STEP file, try re-opening the actual assy from memory instead.  In the File Open dialog, look for "In Session" in the "Common Folders" list on the left.

--
Doug Schaefer | Engineering Manager
Crow Works

Re: Step files keep importing with "temp" part numbers

Doug, thank you so much! That was exactly the problem. Not only does clearing the memory fix the issue, the ability to load from session is super helpful. (I didn't know about either of those options). I figured it was a "working memory" problem but I had no idea how to fix it. Thanks!