cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to colorize wires

SOLVED
Highlighted
Newbie

Unable to colorize wires

I've tried all sorts of combinations:

  • Designating the parts as Wires, Round or Flat
  • Creating Spools of Wire, Cable, Sheath or Ribbon. In all of those I tried bring the Color column and assign a color from the list. Nothing happens: The cable sticks with the default color
  • Tried to apply a material from the Appearance editor. All the cables get the same color in this case: No success.
  • Tried routing cables individually and applying, or in group, then applying: No change.

What's wrong ?

Creo 2

Tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Unable to colorize wires

Try to define appearance gallery color names in lowercase.

View solution in original post

5 REPLIES 5
Highlighted

Re: Unable to colorize wires

Most of that chances that color names in the list don't match color names in your appearance gallery.

If it's a case, you can do one of the following:


1. Manually enter spool color name that defined in the gallery

2. Rename color in the gallery to match those in the spool colors list.

Highlighted

Re: Unable to colorize wires

Dumb me !

I forgot to create the corresponding appearance.

But for some reason, even after matching the color labels with the ones I've created on the appearances, the color is not applied to the wires.

I even wiped everything and re-created stuff from the beginning, with the colors on the appearances already existing. No success.

Highlighted

Re: Unable to colorize wires

Try to define appearance gallery color names in lowercase.

View solution in original post

Highlighted

Re: Unable to colorize wires

Hello Lucas,

the hints from Yakov seem to be good ones (see also article CS172530 about "Appearances defined with capital letters are ignored for color definition in spools in Creo Parametric").

If they helped you solving the issue, please get back and mark his answer as "Correct", to signal the community that the issue is answered.

And if you found another reason for the failure, please let us know.

Thanks,

Gunter

Highlighted

Re: Unable to colorize wires

Thank you both.

Indeed, making them lowercase corrected things up.

I've named both the appearance and the spools just to be sure. All lowercase. Then, after regenerating, the colors fitted.

Thank you again for the solution

Obs.: I was unable to access the provided link for this CS172530 article due to account restrictions.

Announcements