cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

creo 3 M080 layer issue for GTOL datums

SOLVED
Turquoise

creo 3 M080 layer issue for GTOL datums

I have rules-based layers, where all GTOL info, including GTOL datums, are put on a layer.  I can hide that layer in the model yet those datums still appear.  It's driving me nuts, especially on larger assemblies and I don't like using the hide command because that also hides it in the dwg.  Now, if I use the option "In Geometry" it hides as it's supposed to, but I don't WANT it there, because I usually end up putting it in a dimension anyway.

Why did my layer USE to work in creo elements Pro 5.0 yet is doesn't work now?  Looks buggy to me.....

Any ideas?

Grazie!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: creo 3 M080 layer issue for GTOL datums

I got it to work by doing this in the model:

model datum setting.tif

Then doing these in the dwg:

dwg datum settings1.tif

dwg datum settings2.jpg

Edit:  Sorry, I just noticed the "std_iso" setting caused an issue elsewhere, this is the right setting.  Really.  I promise.... 

5 REPLIES 5

Re: creo 3 M080 layer issue for GTOL datums

PTC decided what used to work was all wrong...set datums and layers in Creo 2

My work around is to use "old style set datum" that, by the way, doesn't mean old style like ansi 1982 vs asme1994, it's the old style datum as in the way it used to work.

**EDIT: this is a much better link Re: Tagged Datum Display Issue

Stephen Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: creo 3 M080 layer issue for GTOL datums

I think it's due to the way PTC has changed the way Creo handles annotations. The combination states that you can create from the annotation tab take precedence over the layers. When you make a datum a set datum it adds the datum graphics to the default combination state. You need to remove or erase the annotation from the combination state. As I recall these were not present in Creo Elements Pro 5 or at least it was handled differently.

Re: creo 3 M080 layer issue for GTOL datums

Wow, thanks for the links guys!

Being on a version, like, 7 years out of date, I had no idea this bug was there this long.  Thanks for the links, I'll try some of the work arounds!

Pathetic that they did this, and specifically made things more difficult.  What, did they think we wanted large assemblies full of datum planes we couldn't get rid of???  How is THAT an "enhancement"?  Every time I see something like this I understand why all my SW users complain about dwg mode....ugh.  PTC has yet again shot themselves in the....er....foot.

Re: creo 3 M080 layer issue for GTOL datums

And that gives me the opportunity to promote this idea again "Set Datums" should be hidden by default when placing a new view on a drawing.

I don't have control over all the parts that go in to my assembly, so I can't control the layers the datums are set too. We raised a stink internally and was able to get a bunch of the datums changed and set to a layer which helped...if the part was touched at some point in time recently.

This one pertains also Add ability to hide geometric datum planes But is more like a set datum on/off toggle.

Stephen Williams
Pro/E Version 15/16 (Circa 1995/1996)

Re: creo 3 M080 layer issue for GTOL datums

I got it to work by doing this in the model:

model datum setting.tif

Then doing these in the dwg:

dwg datum settings1.tif

dwg datum settings2.jpg

Edit:  Sorry, I just noticed the "std_iso" setting caused an issue elsewhere, this is the right setting.  Really.  I promise....