cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

datums

Visitor

datums

I'm trying to attach a datum callout to a dimension, but it not allowing me to do it. I get to the point of selectng it, but once I select the dim. it tell me Selected part is not active. Select again. What is wrong?
1 REPLY 1

Re: datums

Hi Aaron,

I don't know why this has gone so long unanswered. You certainly solved this problem several years ago, but for everyone else searching for a solution: read on.

I was having the same problem as you: I wanted to attach a centerplane datum tag to the relevant dimension within a drawing, but Right Click --> "Properties" ---> Placement "In Dim" ("Pick Dim" button) ---> click on relevant dimension always resulted in "Selected part is not active. Select again." The only other "solution" to this problem I could find online recommended setting the config.pro option "create_drawing_dims_only" to "no", but this alone did not fix the problem. (You may still need to do this, as well as the following.)

To solve the problem:

1.) In 3D Model: Create a dimension annotation  (with the correct annotation plane)

2.) In 3D Model: Create a datum plane

3.) In 3D Model: Set datum plane placement to "In Dim" of above dimension

4.) In 2D Drawing: "Show" dimension

To give more detail on the above:

1.) Create a dimension annotation by opening the "Annotate" tab, selecting the "Annotation Plane" that corresponds to the drawing view you would like the dimension to appear, and click "Dimension". Click the features between which you intend to dimension, middle click, and click "Done". (Note that you can also create a dimension through the "Annotation Feature" button, but this method did not work for me.) In your model tree, you should see a dimension under "Annotations".

2.) Create a new datum plane by opening the "Model" tab, clicking "Plane", and selecting whatever references define your plane. Click "OK".

3.) Right click on the plane in the model tree, select "Properties", and name the plane. Select the rightmost of the display options (the "plunger"-style datum display), then select "In Dim" under placement. You can now select the dimension in your model tree and click "OK".

4.) In the drawing, you'll need to "Show" the dimension with the datum attached by opening the "Annotate" tab, clicking "Show Model Annotations", selecting the dimension tab on the pop-up dialog box, and clicking the view in which your dimension should be displayed. This will display all possible dimensions for this view. You should be able to find your dimension with the datum attached, click on it, and then click "Apply". (If you don't see your datum after this is done, you may need to unhide some layers in the relevant view.)

Hope this saves a few people from the headache this problem caused me.

David