cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Logging into Integrity web interface with localhost?

SOLVED
Highlighted
Newbie

Logging into Integrity web interface with localhost?

I've noticed that if I try to access the web interface via localhost:<port> it doesn't work, giving the following error:

Error connecting to <hostname>:<port>: String index out of range: -1

This is despite providing the correct credentials, as evidenced by successful login via the desktop client, as well as when accessing the web interface using 127.0.0.1:<port>.

I have modified the IntegrityClientSite.rc on the server as well as client, which are configured for ICAllowSpecificConnectionPolicy, with 127.0.0.1 in the validConnectionList. Additionally, in the server's IntegrityClientSite.rc, ICLocalConnectionPolicy is set. This isn't a huge deal, but is somewhat of an annoyance that I'd like to resolve if possible. It doesn't seem to change anything when i comment the validConnectionList. Also, the hosts file does include a mapping for 127.0.0.1 to localhost. Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Logging into Integrity web interface with localhost?

Sounds like you are hitting a problem, related to this article:

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS185622&lang=en_US

There is an RFC associated with that article.

IPv6 being enabled, is the most common case, of hitting this issue, but it could be other configuration problems as well, for DNS or the localhost loop back adapter.  I'd check to make sure IPv6 is not being used.

You can attempt to work-around the issue if IPv6 is the problem, by:

Set "mks.java.additional.XX=-Djava.net.preferIPv4Stack=true" in mksservice.conf where 'XX' is the next incremental number.

View solution in original post

1 REPLY 1
Highlighted

Re: Logging into Integrity web interface with localhost?

Sounds like you are hitting a problem, related to this article:

https://support.ptc.com/appserver/cs/view/solution.jsp?n=CS185622&lang=en_US

There is an RFC associated with that article.

IPv6 being enabled, is the most common case, of hitting this issue, but it could be other configuration problems as well, for DNS or the localhost loop back adapter.  I'd check to make sure IPv6 is not being used.

You can attempt to work-around the issue if IPv6 is the problem, by:

Set "mks.java.additional.XX=-Djava.net.preferIPv4Stack=true" in mksservice.conf where 'XX' is the next incremental number.

View solution in original post

Announcements