cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Missing error message when opening 8.3 model with 8.2 client

Missing error message when opening 8.3 model with 8.2 client

When upgrading the Modeler to server version 8.3 you will be noticed by the client 8.3 to upgrade your existing model in the Enabler DB.

If then someone access the same model with a client in lower version (e.g. 8.2), you will again be asked to upgrade your existing model. But in this case it is a downgrade.

This might be a dangerous situation in a productive environment.

 

I suggest to not allow clients with lower version to access on higher server version. At least an error message or a warning should be displayed.

 

Best regards,

Daniel

 

CAE Software & Systems Engineering

Schaeffler Technologies AG & Co. KG

2 Comments
Aquamarine

hi Daniel,

Thanks for the idea and we agree this should be resolved. We have the issue already in our database with the ID: ART04-6422747 and are considering for a future release. The intention would be to not allow users to downgrade models/repositories, but still provide a backdoor way for Admins to do it.

Regards,

Patrick

Aquamarine
Status changed to: Under Consideration