cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

A list of Required Software of ThingWorx

Level 8

A list of Required Software of ThingWorx

I always find it difficult to remember which version of software is supported with which version of ThingWorx, so I created a table for my reference.

I hope this is also helpful to other people.

 

  Oracle JDK Tomcat Database Options Memo
PostgreSQL Neo4J H2 Microsoft SQLServer SAP HANA DetaStax Enterprise Edition
ThingWorx 6.5 1.8.0(64-bit) 8.0.23(64-bit) 9.4.4 embedded N/A N/A N/A N/A IE 10
ThingWorx 6.6 1.8.0(64-bit) 8.0.23(64-bit) 9.4.4 embedded N/A N/A N/A N/A  
ThingWorx 7.0 1.8.0(64-bit) 8.0.23(64-bit) 9.4.? embedded N/A N/A N/A N/A  
ThingWorx 7.1 1.8.0_92-b14(64-bit) 8.0.33(64-bit) 9.4.5 embedded N/A N/A N/A 4.6.3  
ThingWorx 7.2 1.8.0_92-b14(64-bit) 8.0.33(64-bit) 9.4.5 embedded embedded N/A N/A 4.6.3 IE 11 and later
ThingWorx 7.3 1.8.0_92-b14(64-bit) 8.0.38(64-bit) 9.4.5 embedded embedded N/A SPS 11, 12 4.6.3, 5  
ThingWorx 7.4 1.8.0_92-b14(64-bit) 8.0.38(64-bit) 9.4.5 embedded embedded 2014 and later SPS 11, 12 4.6.3, 5  
ThingWorx 8.0 1.8.0_92-b14(64-bit) 8.0.44(64-bit),
8.5.13(64-bit)
9.4.5 embedded embedded 2014 and later SPS 11, 12 4.6.3, 5  
ThingWorx 8.1 1.8.0_92-b14(64-bit) 8.0.44(64-bit),
8.5.13(64-bit)
9.4.5 embedded embedded 2014 and later SPS 11, 12 4.6.3, 5  
ThingWorx 8.2 1.8.0_92-b14(64-bit) 8.0.47(64-bit),
8.5.23(64-bit)
9.4.5 embedded embedded 2014 and later SPS 11, 12 4.6.3, 5  
ThingWorx 8.3