cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Asset Advisor OEM Failed to import

SOLVED
Highlighted
Aquamarine

Asset Advisor OEM Failed to import

AssetAdvisorOemError.jpg

The error messages is like the image above:

SCO_Common-Extension:8.0.0                    Import Failed: java.lang.NullPointerException

AppHomePage-Extension:8.0.0                    Import Failed: java.lang.NullPointerException

I need some help here. What could possibly be wrong here ? Did Someone face the same issue before?

Thank you,
Vinícius Xavier.

Tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Asset Advisor OEM Failed to import

Hi Vinicius,

Java configuration for tomcat is referring to 1.8.0.121 version of jre which looks good to me.

I would suggest you to restart the server and import the extension again.

If the issue still persists , i would recommend you to redeploy the Thingworx.war again.

Thanks,

Himesh Rajpal

View solution in original post

10 REPLIES 10

Re: Asset Advisor OEM Failed to import

Hey Vinicius,

Looks like you don't have the requisite JRE/JDK installed.  Can you verify that you have JDK 8 Update 111 installed?

Milan

Re: Asset Advisor OEM Failed to import

Yes, I have JDK 8 Update 111 installed.


Re: Asset Advisor OEM Failed to import

Greetings Vinicius

Checked the extensions for SCO_Common-Extension:8.0.0, AppHomePage-Extension:8.0.0 and found out that the JDK Version used for Build is 1.8.0_121.

JDK Version.PNG

Could you please try the import again by upgrading the Java version on your system.

Thanks,

Himesh Rajpal

Re: Asset Advisor OEM Failed to import

The same problem again after the java update.

Re: Asset Advisor OEM Failed to import

Hi Vinicius,

Could you please share the java configuration for your tomcat server on which ThingWorx Platform is running ?

It might be pointing to old java version . Need to check that .

Thanks,

Himesh Rajpal

Re: Asset Advisor OEM Failed to import

Hi Himesh,

I paid attention on that. Here follows the image.

Thanks,
Vinicius.

tomcatpoint.jpg

Re: Asset Advisor OEM Failed to import

Hi Vinicius,

Java configuration for tomcat is referring to 1.8.0.121 version of jre which looks good to me.

I would suggest you to restart the server and import the extension again.

If the issue still persists , i would recommend you to redeploy the Thingworx.war again.

Thanks,

Himesh Rajpal

View solution in original post

Re: Asset Advisor OEM Failed to import

Hello Himesh,

Redeploy Thingworx.war woked well.

Thank you very much,
Vinicius.

Re: Asset Advisor OEM Failed to import

Was there any additional information on log files??