cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Asset list not showing in Asset Advisor

pwbridgeman
Regular Member

Asset list not showing in Asset Advisor

Hi,

   I have created a user with the maintenance engineer role. Whenever that user opens Asset Advisor, the mashup master and filter list display as they should, but the asset list does not show up. If I add the controls engineer role to that same user, the asset list displays as it should, but then that user has access to composer, etc..

How can i make the asset list display under the maintenance engineer role?  See pic.

Thanks for any assistance.

 

 

8 REPLIES 8

Re: Asset list not showing in Asset Advisor

Hey @pwbridgeman 

 

that sounds not right, i agree with you.

could you please send me the Thingworx version and MFG apps version you are using so i can validate the behavior you are facing.

 

Thank you! Seb

Seb
Sr. Solution Experience Architect - IoT
PTC

Re: Asset list not showing in Asset Advisor

Hi @SebB

Thanks for the reply. The versions are:

 

ThingWorx Version
8.3.2-b535

ThingWorx Apps
8.3.1-00

 

Paul

Re: Asset list not showing in Asset Advisor

@pwbridgeman ,

 

i just tried to reproduce your problem.

In a new version of Thingworx and the MFG apps a user in the maintenance engineer group can see the assets without problem.

 

I am suggesting to upgrade the system to a newer version, at least the MFG apps to 8.3.2.

It is recommended to match the version with Thingworx.

 

Seb

Seb
Sr. Solution Experience Architect - IoT
PTC

Re: Asset list not showing in Asset Advisor

@SebB 

Thank you for the response.

I just upgraded the ThingWorx Apps to the same version as ThingWorx by importing the extensions and rebooting the server. My versions are now at:

ThingWorx Version -  8.3.2-b535
ThingWorx Apps - 8.3.2-03

 

Unfortunately, I am still having the same problem.

Re: Asset list not showing in Asset Advisor

@pwbridgeman ,

 

when you open the Factory Console or Asset advisor from the Composer via the button "View Mashup" on the mashup entity, you are getting the admin bar on the top of the dashboard.

Open Asset Advisor when you have the admin bar and click on "Show Log", to see when error you are getting. (see screenshot)

 

Seb
Sr. Solution Experience Architect - IoT
PTC

Re: Asset list not showing in Asset Advisor

@SebB 

Here is a screenshot that shows some warnings, but no errors. 

Asset Advisor works correctly under the admin login.

 

 

Re: Asset list not showing in Asset Advisor

@pwbridgeman ,

 

please make sure you are logged in with the user you have problems with to see the error.

 

Seb

Seb
Sr. Solution Experience Architect - IoT
PTC

Re: Asset list not showing in Asset Advisor

@SebB

   My apologies, maybe I am misunderstanding the procedure as you described, but if I am logged in as the user that I am having problems with, I do not have access to composer. If I assign the controls engineer role to the user, he will have access to composer, but at that point the problem does not occur. Please clarify if I am misinterpreting something.

Again, thanks very much for your assistance on this.

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.