cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Connection to Thingworx failed

Re: Connection to Thingworx failed

Hi Himanshu,

 

sorry for this late reply, I took a long leave for some urgent things.  Today I try again, and still cannot connect to the web server. I attached some log files here, fyi. Thanks a lot.

 

Grant

Re: Connection to Thingworx failed

Hey @grantji 

 

the security.log show a http validation error. I found some TechSupport articles to this issue but i am not sure if the causes your connection issue. Could you please send the Application.log file that is in the same folder like the two over log files.

 

Seb

Re: Connection to Thingworx failed

 

Re: Connection to Thingworx failed

Thanks @grantji 

 

but the log is full with ThingWatcher Messages.

Could you send me the archive folder that is in the log folder to see older log files.

 

Seb

Re: Connection to Thingworx failed

Hi Seb, I got the log files under C:\Program Files (x86)\twxFoundationH2Trial-8.3.2\tomcat\apache-tomcat-8.5.23\ThingworxStorage, pls see the attachment. If need, I can send the teamviewer connection to you. Thanks in advance!

 

Re: Connection to Thingworx failed

It looks like you have not used the free trail installer for the setup

I dont see any connecting try in the logs.

I would like to take a look an the system, i send you a pm.

 

Seb

Re: Connection to Thingworx failed

Thanks Seb. I also think the Industrial connectivity didn't try to connect to the Tomcat server, not sure if there is any environmental configuration problem. Because the timezone is difference for us, I will email you next Monday, have a good weekend!  

 

Grant

Re: Connection to Thingworx failed

Hey @grantji ,

 

i could find the problem. I changed the connection information in KepServerEx from localhost to 127.0.0.1. for some reason localhost is blocked on the server. i assume its a security setting.

I haven not looked deeper into it.

 

The connection to Thingworx should work now.

 

Seb

Re: Connection to Thingworx failed

Hi Seb,

 

It works now. This problem really perplexed me for a long time. Thank you very much for your big help.

I remember that I ever enable "127.0.0.1 localhost" in C:\Windows\System32\drivers\etc\hosts, and I can access "http://localhost/Thingworx/" in Internet Explorer, I am wonder why the localhost doens't work for Industrial Connectivity. Is there any security setting in Industrial Connectivity? Thanks again and have a good day!

Re: Connection to Thingworx failed

@grantji 

 

I am not aware of any security setting in Industrial Connectivity that could be responsible for that.

Maybe its the Windows firewall or any setting on the host.

 

Seb