cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

DemoFactory - Control Console not working

SOLVED
mariaaliceduart
Participant

DemoFactory - Control Console not working

I installed the Demo Factory following the steps in "Installing the ThingWorx for Manufacturing Demo Factory.pdf" document.

 

STEP 3 – IMPORT THE KEPWARE SIMULATOR CONTROLS - OK 

STEP 4 – ADD A TILE TO THE CONSOLE TO LINK TO CONTROLS MASHUP - OK

STEP 5 – IMPORT THE TAG DATA INTO DATA TABLE - Seems to be OK

STEP 6 – UPDATE THE LABEL FOR THE CONTROLS TILE - Seems to be OK

 

The tile is added to the Console linked to Controls mashup, but the label in the tile is not ok (shows ????) and when I open the controls mashup it seems to be not connected.

 

 

 

 

Console - New Tile.png

 

 

Controle Console.png

 

Thank you,

 

Maria Alice 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: DemoFactory - Control Console not working

Hi @mariaaliceduart,

 

Thanks again for the detailed explanations. It looks like you may have an unintended space or <LF> in your text entry for "PTC.DeveloperProgram.ControlAdvisorLabel" between "PTC." and "Developer". This can happen sometimes when copying/pasting from the pdf instructions.

 

Can you try pasting the text into Notepad first, to validate it's correct, before pasting into the Localization Token in Mashup Builder?

 

 

Best regards,

Steven M

View solution in original post

7 REPLIES 7

Re: DemoFactory - Control Console not working

Hi Maria Alice.

 

Did you validate the connectivity with KEPServerEX in steps 2.2 and 2.3?   In Controls Advisor, is the simulator status green? What do the logs show?  Step 6 does not appear to have worked since the name of the tile has not changed, so you may want to try that step again.

 

If you still have issues once you've reviewed the instructions, please provide more information regarding your configuration, such as ThingWorx Manufacturing Apps and KEPServerEX versions, etc., as well as screenshots.

 

If my response has answered your question, please mark as Accepted Solution, for the benefit of others who may have the same question.

 

Regards.

 

--Sharon

Re: DemoFactory - Control Console not working

Hi @mariaaliceduart,

 

I agree with Sharon, it looks like you may have missed a detail in Step 6 (the document in discussion is attached). This step can be a little confusing. To explain a little more:

 

-Open Composer, open and edit any Mashup that contains a Label

-In the Widget browser, select a Label

-In the lower-left Widget Properties menu, locate the Localization field. Select the Globe icon to open the Localization table. Then create a New Localization token

-Enter the Token Name and String Value from Step 6 in the pdf.

 

After a Save and Refresh, you should find the App Icon is now called "Custom Controls". Do you find this is true?

 

 

Best regards,

Steven M

Here

Re: DemoFactory - Control Console not working

Greetings,

 
 
ThingWorx Version 8.1.0-b52
ThingWorx Apps 8.1.2-00
 

 

The connectivity with KEPServerEX in steps 2.2 and 2.3 were checked and is OK.

In Controls Advisor, the simulator status is green.Controls Advisor.png

 

 

I tried the Step 6 again.

Opened Composer, opened and edited Mashup KEP_ControlConsole.

Selected Label "KEP Control Console". 

Selected the Globe icon to open the Localization table.

Label.png

 

 

Created a New Localization token.NewLocalization.png

 When I select Add Localization Token, it says already exists.MsgExists.png

 

Saved and refreshed. 

 

Still not working:Console.png

 Console2.png

 

 

In Log, there is an error message:

[context: com.thingworx.webservices.context.HttpExecutionContext@4704cb5e][message: Execution error in service script [Controller ReadProperty] : Wrapped org.apache.http.conn.HttpHostConnectException: Connect to 127.0.0.1:39320 [/127.0.0.1] failed: Connection refused: connect Cause: Connect to 127.0.0.1:39320 [/127.0.0.1] failed: Connection refused: connect]

 

 

 

Thank you,

Maria Alice

 

 

Re: DemoFactory - Control Console not working

Hi Maria Alice.

 

Which version of KEPServerEX are you running?  Are both ThingWorx and KEPServerEX running on the same machine?

 

Regards.

 

--Sharon

Re: DemoFactory - Control Console not working

KEPServerEX 6.4.

yes, both running on same machine.

 

Production Advisor and Asset Advisor work fine.

Re: DemoFactory - Control Console not working

Hi @mariaaliceduart,

 

Thanks again for the detailed explanations. It looks like you may have an unintended space or <LF> in your text entry for "PTC.DeveloperProgram.ControlAdvisorLabel" between "PTC." and "Developer". This can happen sometimes when copying/pasting from the pdf instructions.

 

Can you try pasting the text into Notepad first, to validate it's correct, before pasting into the Localization Token in Mashup Builder?

 

 

Best regards,

Steven M

View solution in original post

Re: DemoFactory - Control Console not working

Greetings,

 

That was the problem with tile label. Thank you.

 

The connection problem with Control Consol was a java installation missing to get KEPServerEX IoT Gateway working.

 

Thank you for the help.

Announcements

Check out the upcoming Expert Session: Understanding ThingWorx Navigate Licensing in Community "Customer Events" section.