cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Kepware to Thingworx Connectivity

SOLVED
Level 7

Kepware to Thingworx Connectivity

I am using the ThingWorx 30-day trial and trying to connect to Kepware.  The kepware instance is on my local machine.  

 

My settings in kepware match the application ID and thing name exactly.

 

I have verified this many times.  I have also tried messing around with the three "Yes/No" responses to the point where I have tried every combination.

 

Here is the error I get in Kepware:

Connection to ThingWorx failed. | Platform <hostname>:<port>/Thingworx/WS, error: could not establish a websocket connection

 

Does anyone know what might be causing this?

 

Thanks in advance!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Kepware to Thingworx Connectivity

Steven,

 

8080 did the trick!!!  I am not sure how that is determined.  I had tried 80 before and your documentation suggests 443.  I would not have thought to try 8080.  However that did work but for future can the port be user assigned?

 

5 REPLIES 5

Re: Kepware to Thingworx Connectivity

Hello @drluggo,

 

Refer to the solutions contained in this thread:

 

https://community.ptc.com/t5/Manufacturing-Apps/cannot-connect-to-Thingworx-from-Kepserverex-V6-Thin...

 

Please let us know how it goes after going through these settings and suggestions.

 

 

Thanks & Regards,

Manoj Pathak

 

Re: Kepware to Thingworx Connectivity

Hi @drluggo.

 

From the screenshot of your KEP_settings, can you validate if the host name is correct?  It's difficult to tell.

 

It's also somewhat easier to validate the settings needed for KEPServerEX by going to Controls Advisor in Manufacturing Apps, selecting the connection, then clicking the key (see screenshot).  Then you can copy/paste to the KEPServerEX config for ThingWorx.

 

ControlsAdvisor.PNG

 

Please let us know if you still have issues once you have validated these settings.

 

Regards.

 

--Sharon

Re: Kepware to Thingworx Connectivity

Greetings @drluggo,

 

Adding another suggestion to the mix, it looks like you may have the incorrect port entered.

 

Try these settings in the KEPServerEX Project Properties:

Port: 80

Trust self-signed certificates: No

Trust all certificates: No

Disable encryption: Yes

 

If that does not work, try Port 8080. If it is still not working, we will need to figure out the Port that ThingWorx is configured to use. What is the Port being used when you connect Composer in a web browser?

 

 

Best regards,

Steven M

Re: Kepware to Thingworx Connectivity

Steven,

 

8080 did the trick!!!  I am not sure how that is determined.  I had tried 80 before and your documentation suggests 443.  I would not have thought to try 8080.  However that did work but for future can the port be user assigned?

 

Re: Kepware to Thingworx Connectivity

Greetings @drluggo,

 

Thank you for confirming the solution. An additional request for you here, please mark the appropriate post with "Accept as Solution" for the benefit of others who may have the same question.

 

 

For the additional question you had about configuring the TomCat port, see this Reference Documentation for more information on the Port selection during install, and how to access the Tomcat server.xml configuration file:

 

The Installing Oracle Java and Apache Tomcat (Windows) section of the ThingWorx 8.2 Installation Guide

 

Article - CS195506 Configuring Tomcat for ThingWorx Installation

 

Best regards,

Steven M