cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Manufacture App Control Advisor not view Industrial Connectivity server

SOLVED
Level 6

Manufacture App Control Advisor not view Industrial Connectivity server

A similar problem was described and solved for previous versions of THX:
https://community.ptc.com/t5/Manufacturing-Apps/Control-Advisor-App-Kepware-server-added-but-not-vis...
The solution to this issue was to install updates. What can be done in this case?

Versions :
Windows 7x64 maximum SP1
Tomcat 8.5.30
Postgres 10.3.3
ThingWorx 8.3.3-b937
Manuf Apps 8.3.1 Extension
Industrial Connectivity 8.3.65

Everything is installed and run smoothly.

Connection with TWIC and tags are available in the composer.

But the problem I have is that in my App Control Advisor, the list of Servers is empty.
Even when I add new server the created server is not displayed.
If i try to create the server again in the Control Advisor App a message tells me that the server already exists, which is normal.

All screenshots are similar to the post to which I refer.

Thank you, Peter.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Manufacture App Control Advisor not view Industrial Connectivity server

Problem solved. Information could not be found in any source. Special thanks SebB.

 

Decision:
1. Create a server in the thingworx controls advisor (sample: kepadvisor1). Creating a connection in THW is not necessary.
2. After that, a pop-up window appears. (Screenshot in the application).
3. Enter all data from this window into TWIC (Project/Property Editor/ThingWorx) and establish a connection.
4. Now all tags are available in THW as thing "kepadvisor1" . (Industial connections "kepadvisor1-GW"). For Advisor server name remains "kepadvisor1".

 

Best regards.Peter

7 REPLIES 7

Re: Manufacture App Control Advisor not view Industrial Connectivity server

Hi @domrachev ,

 

From your details i saw that you are using Postgres 10.3.3 version with ThingWorx 8.3.3 which is not supported for this ThingWorx version. The latest version of postgres supported for ThingWorx 8.3.3 is 9.4.9.

Please refer ThingWorx 8.3 System requirements for details.

 

Also please confirm your Industrial Connectivity is 8.3.65.

 

Please try installing thingworx as per the specifications and validate the issue.

 

One more point you can check is open the Industrial Connections in new composer and check the server name exists over there or not. If it exists please check connections status in properties tab.

 

Thanks,

Himanshu

Re: Manufacture App Control Advisor not view Industrial Connectivity server

I reinstalled the operating system and all applications, and I also had to update the license. Now it looks like this:

Windows 10x64 Enterprise 2016 LTSB
Tomcat 8.5.23
Postgres 9.4.21-1
ThingWorx 8.3.3-b937
Manuf Apps 8.3.1 Extension
Industrial Connectivity 8.3.65 ( V6.5.828.0)

In the Composer, I see all the tags, in the old and new versions. In the Advisor can not see the server.
I attach screenshots to the message text.

Thank you, Peter.

Re: Manufacture App Control Advisor not view Industrial Connectivity server

Peter,

 

Controls Advisor is adding tags and ThingShapes to the object and is just showing server that has this specific configuration in the UI. Could you please send a screenshot of the Industrial Thing general page of the object that you have create from Controls Advisor. Controls Advisor also creates a proxy thing with the name of the Kepware server as normal thing that will holed all tags, could you see if this object gets created.

 

Seb

Re: Manufacture App Control Advisor not view Industrial Connectivity server

Can you provide more detailed instructions?
Best regards Peter.

Re: Manufacture App Control Advisor not view Industrial Connectivity server

Peter,

 

make sure you create a new server in Controls Advisor, then check the Industrial Connectivity section in the Composer if the object with the "-GW" extension on the name got created and check if an Thing with the name of the Kepware server got created as well.

 

For clarification:

When you create a new server in Controls Advisor it creates two objects in the background.

The Industrial Connectivity thing with a "-GW" on the end of the name and a proxy thing with the same name without the "GW" that will hold all the Kepware Tags that you bind in the MFG apps. 

 

Make sure both objects get created.

 

Seb

 

Re: Manufacture App Control Advisor not view Industrial Connectivity server

Problem solved. Information could not be found in any source. Special thanks SebB.

 

Decision:
1. Create a server in the thingworx controls advisor (sample: kepadvisor1). Creating a connection in THW is not necessary.
2. After that, a pop-up window appears. (Screenshot in the application).
3. Enter all data from this window into TWIC (Project/Property Editor/ThingWorx) and establish a connection.
4. Now all tags are available in THW as thing "kepadvisor1" . (Industial connections "kepadvisor1-GW"). For Advisor server name remains "kepadvisor1".

 

Best regards.Peter

Re: Manufacture App Control Advisor not view Industrial Connectivity server

Hey @domrachev 

 

nice to hear that you solved the problem.

Here you can find a guide that explains the process if you look for more information (Step 5 shows how to connect KepServerEx): 

https://developer.thingworx.com/en/resources/guides/configure-manufacturing-apps

 

Seb