cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with Custom Control Apps Display in ThingWorx Manufacturing Apps Factory Demo

SOLVED
Visitor

Problem with Custom Control Apps Display in ThingWorx Manufacturing Apps Factory Demo

Currently, I'm doing a Projects & Guides with the name 'Connect Factory Assets Using Controls Advisor (Guide 1)' in ThingWorx Developer Portal. I use ThingWorx Manufacturing Apps Trial as instructed by the guide. 

I use:

-ThingWorx-Manufacturing-Apps-8.3.0-05.exe (all in one installer) with the port config set to 8080 (default 9080)

-KepServerEx 6.3

(both in the same machine)

 

I have followed all the instruction and step until I found a problem in Step 4: Monitor Servers, Assets and Devices, right after I open the Custom Control Advisor Menu it show error like this picture below :

Error Manufactur App.jpg

 

Looking back to Step 3: Configure Factory Simulator Data, all instruction until load data-0.twx, in ThingWorx Composer, results in a successful message. 

When I check ApplicationLog in Monitoring in Sidebar Menu, it shows:

[context: com.thingworx.webservices.context.HttpExecutionContext@5efc02c0][message: Execution error in service script [ReadProperty] :: Connect to 127.0.0.1:39320 [/127.0.0.1] failed: Connection refused: connect]

I check in controller service script and there are 6 scripts, one of the is ReadProperty as mention in the error, but no clue which one is the suspect.
So, anybody knows what is happening here?

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Problem with Custom Control Apps Display in ThingWorx Manufacturing Apps Factory Demo

Greetings @aadiwilaga,

 

This issue usually occurs due to 32-bit Java missing on system.

Please install latest version of 32-bit Java JRE (or JDK) for the relevant platform running KEPServerEX and change the KepServerEX settings so that IoT Gateway point to 32 bit JRE. PFB screenshot for reference.

 

 

Capture

 

Thanks,

Himanshu

 

View solution in original post

2 REPLIES 2

Re: Problem with Custom Control Apps Display in ThingWorx Manufacturing Apps Factory Demo

Greetings @aadiwilaga,

 

This issue usually occurs due to 32-bit Java missing on system.

Please install latest version of 32-bit Java JRE (or JDK) for the relevant platform running KEPServerEX and change the KepServerEX settings so that IoT Gateway point to 32 bit JRE. PFB screenshot for reference.

 

 

Capture

 

Thanks,

Himanshu

 

View solution in original post

Highlighted

Re: Problem with Custom Control Apps Display in ThingWorx Manufacturing Apps Factory Demo

I not to understand why, but reinstalling the java and reconfigured the setting to installed JRE works, although it is the same JRE. but many thanks.

(I have installed ThingWorx 8.0 before in my machine but then uninstall it, and change to this Manufacturing Package. Maybe have some unclean data or somthing)

Announcements
LiveWorx Call For Papers Happening Now!