cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

Surface finish with volume rough

RJ_FR
8-Gravel

Surface finish with volume rough

Hello,

I have a problem of surface finish with a volume rough.

The previous operation leaves 0.2mm of stock (walls and bottom)  for the finish with my volume rough.  I choose a spiral toolpath and i have sharp edges between each trajectory segments. In the real world this create micro stops of the servos of my milling machine and a very bad surface finish.

 

000984.png

 

So i decide to apply a radius with the option "Smooth_corner_radius = Max radius" and "Smooth_radius = 1" (End mill of 6mm diameter).

The problem :

The calculated trajectory miss some areas of my surface...

000983.png

Same problems with "constant_radius" and angle_radius" for "Smooth_corner_radius", smaller radius value and thinner "step_over".

 

Some ideas ?

 

Thanks in advance

5 REPLIES 5
pushkarkhanna
13-Aquamarine
(To:RJ_FR)

Hello

 

There is the parameter circ_interpolation that should be set to arc_only, is it is set to points_only then also it gives the interpolation as different points curve points. Please check this out

 

Regards

Pushkar

Hello,

 

 circ_interpolation is set to arc_only on my configuration.

MartinHanak
24-Ruby II
(To:RJ_FR)

Hi,

please report the problem to PTC Support, too.


Martin Hanák
RJ_FR
8-Gravel
(To:RJ_FR)

Hello,

 

I found a lead, i think it is not a bug but a geometry problem. I sketch the case with 90° trajectory :

 

Blue, first pass, pink second with my parameters : 

tool_diameter = 6mm

step_over = 5mm

radius = 3mm

000986.png

It remains a little part of material as i can see in simulation.

And 90° is the simpliest case... 

 

I found this in help :

000987.png

 

The problem is that Creo does not calculate the radius with the option "Max_radius", it is always the max...

 

With this parameters it seems to work in any case :

step_over = 75% of tool_diameter

radius = 10% of tool_diameter

Daniel_E
6-Contributor
(To:RJ_FR)

Smooth sharp corners doesn't seem to be a "smart" option; I mean it just blindly adds a radius to all the sharp corners.  Can you reduce the "step over" so it catches the leftover material?


But if the sharp corners are your issue, can you switch to a different tool strategy?  Like "Constant Load"?  You can specify a minimum radius with that strategy, and it will adjust to make sure material isn't left over.  

Top Tags