cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Help us improve the PTC Community by taking this short Community Survey! X

Language

Manfred_F
6-Contributor

Language

I have a german installation of Prime 7. As I work for an international company, we use english in our documents. When I input text, the spell check always switches to german. So I have to manually format every text to english. How can I force MathCad to spell check in english as  default?

3 REPLIES 3

I am using a German installation of Prime, too, and can confirm the problem. The language may be set to "English" even in a template file, but whenever a new text region is created and I start to type, it automatically switches back to  "German" so it must be manually set to "English" again and this has to be done for every single text region created. Very annoying! I see no way to change this behaviour but as I generally found the Prime spell checker less helpful I turned it off by default (and thankfully this is working without having to turn it off for every file individually).

 

Speaking of language settings and annoyances - I like to have the menus in English and the only way to achieve this is to add "/culture:en-US" to the call of Prime.exe by creating an appropriate shortcut. This unfortunately does not affect the error messages which usually are still in German or quite often a silly mix of German and English.
But the worst is that it only works if you start Prime using the shortcut. Double clicking a Prime file or directly opening a Prime sheet posted here in the forum still would use the German version of Prime. It would be necessary to add "/culture:en-US" at various places in the registry to make it work as it should.

It would be much easier and more reasonable if Prime would use a simple configuration file for setting the language as well.
But it seems that the developers have something against reasonable and usable solutions. This is also shown by such elementary things like scrolling in larger matrices. How this was implemented in Prime is terrible and almost unusable! One often gets the impression that there are no professional developers working, but a few boys who enjoy playfully trying out a few ready-made toolboxes ("Hey, mom! Look what I can do!").

 

Manfred_F
6-Contributor
(To:Werner_E)

Hi Werner thanks for the tip using the parameter. I usually have everything installed in the english version, but with Prime I didn't have the choice (my company's IT). German versions often have odd translations....

One hint from me, if you want to change everything to a certain language, click on an empty place inside the document (outside of a chapter), hit ctrl-A (for select all) and format it to "english".


@Manfred_F wrote:

Hi Werner thanks for the tip using the parameter. I usually have everything installed in the english version, but with Prime I didn't have the choice (my company's IT). German versions often have odd translations....


🙂 Yes, thats exactly the reason why I too prefer to have the english version installed.
In real Mathcad an additional reason to do so was that I did not like the "Germanized" keywords. While the original english ones would be accepted as well, the help only showed the German ones and they really were somewhat strange. It was a good idea (one of very few) not to translate commands and keywords in Prime but leave them in English.

 


One hint from me, if you want to change everything to a certain language, click on an empty place i the spell checknside the document (outside of a chapter), hit ctrl-A (for select all) and format it to "english".


Thanks. That should work at least for already created Text regions. New text regions still would default to German, though. But as I wrote I usually have the spell check disabled anyway. Maybe just because I am used to do so so in real Mathcad (version 15 and below).

 

Top Tags