cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Mathcad 14 64bit vista suspected bug

jasonthecat
1-Newbie

Mathcad 14 64bit vista suspected bug

Hello,

There seems to be a rendering bug in the 64bit version of Mathcad R14. i am running Mathcad 14.0 M011. The 3D plots are not visible in the rectangular window:-( If I move the mouse, I can see that they are there but they cannot be seen. This is true of the quicksheets as well. 2D plots render fine on the screen. Is there something that I have not configured properly or is this a bug?
15 REPLIES 15

Mathcad's 3D graphics have never been right. They have always worked only with a limited selection of video cards, and even then often only with specific versions of the drivers and/or acceleration settings. Mathsoft has never shown the slightest interest in even diagnosing these problems (much less doing anything about them). There viewpoint seems to be that if it works with the hardware and software used by their staff, it is good enough, and if the erstwhile customer has problems he should simply get the same configuration.

You can try turning down the video acceleration features. If that works, you will have to decide whether Mathcad is important enough to live with the degraded video performance. There may be otehr settings, like the aero interface, that may be unsettling to Mathcad. Or you can try contacting PTC to find out what video configuration (video card and driver version and Video options) they used for their 64 bit testing, and then duplicate that on your system.
__________________
� � � � Tom Gutman

It's not quite that bad, we just can't test every single graphics and video card.

Go to the Mathcad support page knowledge base and search on 3D graphs for Mathcad 13 under Articles, and scroll down to Plots. Often the problem is fixed by upgrading your video or graphics card.

Mona
SteenGroðe
6-Contributor
(To:mzeftel)

At some point they (staff at Mathsoft) made a setting in the registry that do fix some issues:
[HKEY_CURRENT_USER\Software\Mathsoft\3-D Plot]
"ForceSoftwareRendering"=dword:00000001

But sure a couple of issues has long needed a fix and there is a lot of documentation that has never been made public.

Steen Gro�e

>>At some point they (staff at Mathsoft) made a setting in the registry that do fix some issues:
[HKEY_CURRENT_USER\Software\Mathsoft\3-D Plot]
"ForceSoftwareRendering"=dword:00000001<<

I don't think I had seen this. Is it in the knowledge base (the one accessible to mere mortals) or is it something handed out privately to preferred customers (or perhaps squeaky wheels)? It looks like what it does is the same as turning off acceleration, but restricted to Mathcad rather than applying to every application in the system, even those that are properly written so that they work with the hardware rendering.
__________________
� � � � Tom Gutman

>>It's not quite that bad, we just can't test every single graphics and video card.<<

Agreed. But there are some things that could have been done that weren't.

One is to write code strictly to specifications, following all the rules laid out in the documentation. In contrast to what I believe has been done, which is to write code based on experimentation, doing whatever seems to work.

And while testing every single card is impractical, it is unreasonable to completely ignore whole major families, such as the S3 (may not be relevant now, but certainly were when I started with MC2001i), simply writing the off as incompatible.

There are not that many lines of video adapters, it is not unreasonable to test a dozen or so cards representing the most common cards with representatives of all lines.

Nor is it unreasonable, after so many years, for somebody to track down what Mathcad is doing wrong that it so commonly fails with standard acceleration features.

Vista and 64 bit drivers are new enough that one can expect some problems with some configurations. But what is PTC's official response to these problems? Will they continue the tradition of simply saying that it is imcompatible, and telling the user to change his settings, his OS configuration, and perhaps even his hardware? Or will they accept responsibility for their product and look into the problems and provide fixes for them?

__________________
� � � � Tom Gutman
PhilipOakley
5-Regular Member
(To:TomGutman)

We have a 'minor' (in comparison) problem with the companies HP tower systems with embeded graphics chips (Intel).

A plain 3d graphic works OK but when the sheet is scrolled up and the graphic reaches the edge of th screen it scrolls at double rate so that a bar eappears at the bottom of the graph.

This will also occur across a set of side by side 3d graphics.

Everyone grumbles about it. There was a Mathsoft problem ticket on it!

Philip Oakley

>>A plain 3d graphic works OK but when the sheet is scrolled up and the graphic reaches the edge of th screen it scrolls at double rate so that a bar eappears at the bottom of the graph. <<

Oh, that? I've long considered proper scrolling of 3D graphics at the window edge a lost cause. I simply expect that I will have to use ctl-r to get my display back to usable.
__________________
� � � � Tom Gutman
PhilipOakley
5-Regular Member
(To:TomGutman)

On 3/27/2008 1:21:01 AM, Tom_Gutman wrote:
>>>A plain 3d graphic works OK but when the sheet is scrolled up and the graphic reaches the edge of th screen it scrolls at double rate so that a bar eappears at the bottom of the graph. <<
>
>Oh, that? I've long
>considered proper scrolling of
>3D graphics at the window edge
>a lost cause. I simply expect
>that I will have to use ctl-r
>to get my display back to
>usable.
>__________________
>� � � � Tom Gutman

Glad to hear it confirmed by someone. Does anyone else have this problem?

The maththsoft repiort was "Scrolling of Graphics (Ticket 001-00-042524) - Mathcad".

The PC configuration is HP-compaq tower systems (dc7600 CMT base unit) with integral
Intel 82945G Express Chipset.

Philip Oakley

I had this problem once on my 32-bit computer with an older version of Mathcad. I am posting this for anyone who doesn't know how to turn down the hardware acceleration. This is how to do it on Win XP. Right-click on the desktop and go to Properties. Go to the Settings tab and click the Advanced button. Click on the Troubleshoot tab. Underneath "Hardware Acceleration" there should be a slider that you can use to decrease/increase. You may have to experiment with how far down you must turn this to get the graphs to display.

For the record, I am having problems (not showing surface plots)with Vista 32 bit on a Toshiba L300D with 3Mb memory. The graphics card is an ATI Radeon 3100 version 8.479. Thought it was a memory problem so I upgraded that but still no 3D graphs

Here are three possible solutions for problem displaying 3D graphs in Mathcad:

1. Update your video driver by downloading and applying the most recent driver from the video card manufacturer's website.

2. Turn the Hardware Acceleration down or off: Right click on your desktop and choose Properties (or from the Start menu choose Settings/Control Panel/Display.) Go to Settings/Advanced and click on the Performance Tab (in Windows 2000 choose Troubleshooting). Use this setting to decrease Hardware Acceleration.

3. Change the color depth since some cards are designed to perform better at certain color depths. Right click on your desktop and choose Properties (or from the Start menu choose Settings/Control Panel/Display.) Go to Settings, and in the Colors field adjust the setting up or down.

Mona

The current most common problem with 3D plots is the frame being filled and overlaying the actual plot. Turn of the frame and see if you see the plot.
__________________
� � � � Tom Gutman

On 10/21/2009 3:56:14 PM, Tom_Gutman wrote:
>The current most common problem with 3D plots is the frame being filled and overlaying the actual plot. Turn of the frame and see if you see the plot.

Hi Tom. I don't understand what you are saying, but know people that have problems with 3d plots, in windows vista 32 or 64 bits. �Can you explain more about how to turn the frame off, please?

Thanks in advance. Alvaro.

In the properties (double click) under general under frames turn of the show border.
__________________
� � � � Tom Gutman

On 10/21/2009 8:07:21 PM, Tom_Gutman wrote:
>In the properties (double click) under general under frames turn of the show border.

Oh! Thanks! I forgot the acepcion frame = border, and thinkig in something related with animations. This is, a translating lapsus. I remember a mathcad installation where some 3d plots appear and others not, and this in the same worksheet! The reason of that stay in the absolutely dark for me, but with this tip have more sense.

Regards. Alvaro.
Announcements
Check out the latest
Mathcad Tip
"PTC Mathcad 15 / Prime 1-6 Update."