cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Kepserver 6.5 - FANUC - FOCAS 2 - Read Dynamic2 Data Values

SOLVED
MatiasBertoni
5-Regular Member

Kepserver 6.5 - FANUC - FOCAS 2 - Read Dynamic2 Data Values

Hello communty

 

We have a Model Controller 0i-F

 

We are using Open Model in a device created with FOCAS library

 

We configured like that in Kepserver 6.5

 

1 Device CNC1 Model Open.PNG2 Device CNC1 Communication par.PNG3 Device CNC1 Uns T Control.PNG

Now, we choose Open Model but I can't get this tag from the CNC: cnc_rddynamic2_ActS and many others, but we need to star with one

We configured the tag like that:

4 Tag Speed.PNG

 

In Quick Client we see Good Quality but the value = 0

 

 

4 Tag Speed en Quick Client.jpeg

 

What o where we need to configurate to read de value?

 

Thanks @bmacri for your help in the last topic.

1 ACCEPTED SOLUTION

Accepted Solutions

Hello Sharon, 

 

Yes, the last week we get the solution, the problem was the Kepserver version.

 

There is very few information, it is an opportunity for improvement for Kepserver.

 

For us, to solve this problem had importan cost for the project, in money and in time

 

In the next picture you can view the difference the Focas function ables in the differents versions

 

 

 

MatiasBertoni_0-1626471586306.png

 

it isn´t neccesary to use the program UMsgServ.exe

 

Thanks for you support

 

Matías

View solution in original post

8 REPLIES 8

Greetings Matias,

 

Thanks for the inquiry. It is odd that you are receiving good values on some of the tags and incorrect data on some tags. It is usually all or nothing with Fanuc tags.  The first recommendation is going to be to upgrade to the latest release of KEPServerEX v6.10. We have made several changes to the Fanuc driver since the v6.6 release that affect the variety of tags we can now read from.  If the upgrade does not resolve the issue, we will have to have you open up a support ticket so we can leverage our developer's input. Here is a link to our My Kepware portal where you can log a ticket if necessary:

 

https://my.kepware.com/mykepware/s/

 

Thanks,

 

Chris Morehead

Senior Technical Support Engineer

Kepware - A PTC Company

Thanks Chris, 

In my PC I have Kepserver 6.5 but in develope server we have the Kepserver version is 6.9 and and others two PCs we are using version 6.10 with similar bad results. 

 

When I say the tag has quality GOOD and value cero (0) I want to say like the picture shows. 

 

We couldn´t get any values from CNC yet

 

4 Tag Speed en Quick Client 2.jpeg

 

Neither label returns a non-zero value (0)

 

Thanks for your help.

Matías

 

 

Hi Matías,

What does the event log say in KEPServerEX?  I'm guessing there are error messages and knowing what they are should help trouble shoot the issue.

 

Thanks!

-Ben

Hello, we checked in event log say in KEPServerEX and Kepserver has problem to lunch UMsgServ.

 

UMsgServ is running in the server......

 

UMsgServ error_LI.jpg

Hi Matías,

 

Like Chris said above, you really need to open a ticket.  To get a solution to this issue, there are a lot of questions that need to be answered and opening up a support case is the only way to do it.  Here is the link again:

https://my.kepware.com/mykepware/s/

 

Thanks!

-Ben

Hi @MatiasBertoni

 

Did you find a solution to your problem?  If so, please post it here for the benefit of others with the same issue.

 

If you opened a case that is still being worked, please provide the case number by private message so I can track it.

 

Regards.

 

--Sharon

Hello Sharon, 

 

Yes, the last week we get the solution, the problem was the Kepserver version.

 

There is very few information, it is an opportunity for improvement for Kepserver.

 

For us, to solve this problem had importan cost for the project, in money and in time

 

In the next picture you can view the difference the Focas function ables in the differents versions

 

 

 

MatiasBertoni_0-1626471586306.png

 

it isn´t neccesary to use the program UMsgServ.exe

 

Thanks for you support

 

Matías

View solution in original post

Thank you, @MatiasBertoni, for providing the solution.  We're sorry for the difficulties you encountered.

 

Regards.

 

--Sharon

Announcements