cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - If community subscription notifications are filling up your inbox you can set up a daily digest and get all your notifications in a single email. X

Manufacturing Apps not importing

hjimene3
6-Contributor

Manufacturing Apps not importing

Hey team!

I'm working with one of our integrators to install MFG Apps (release 9.1) in thingworx 9.2 but we're not able to make the import.

We tried troubleshooting it, including changing the import permissions in the settings.JSON file but once we save the changes, tomcat doesn't start.

I looked through the logs but I was hoping you could help me guys to see if I missed anything important related to the errors that appear there. 

 

Thanks in advance!

 

1 ACCEPTED SOLUTION

Accepted Solutions
slangley
23-Emerald II
(To:hjimene3)

Hi @hjimene3.

 

It sounds like you didn't add the extension import policy to the correct location in platform-settings.json.  If should be under PlatformSettingsConfig as in this example:

{
    "PlatformSettingsConfig": {
        "AdministratorUserSettings": {
            "InitialPassword": "PtC@1234567890"
        },
        "ContentTypeSettings": {
            "supportedMediaEntityContentTypes": [
                "image/svg+xml",
                "image/png",
                "image/gif",
                "image/bmp",
                "image/jpeg",
                "application/pdf",
                "image/vnd.microsoft.icon"
            ]
        }
    },
        "ExtensionPackageImportPolicy": {
             "importEnabled": true,
             "allowJarResources": true,
             "allowJavascriptResources": true,
             "allowCSSResources": true,
             "allowJSONResources": true,
             "allowWebAppResources":true,
             "allowEntities": true,
             "allowExtensibleEntities": true
        },
    "PersistenceProviderPackageConfigs": {
        "MssqlPersistenceProviderPackage": {
            "ConnectionInformation": {
                "driverClass": "com.microsoft.sqlserver.jdbc.SQLServerDriver",
                "jdbcUrl": "jdbc:sqlserver://localhost:1433;databaseName=thingworx;applicationName=Thingworx;",
                "password": "twadmin@12345",
                "username": "twadmin"
            }
        }
    }
}

 

If it's a syntax error, you can validate the syntax in platform-settings.json at this site, or provide your platform-settings.json here for review.

 

Regards.

 

--Sharon

 

 

View solution in original post

3 REPLIES 3

 Hi,

 

Please send your logs to PTC's technical support, here: https://support.ptc.com/apps/case_logger_viewer/cs/auth/ssl/log 

slangley
23-Emerald II
(To:hjimene3)

Hi @hjimene3.

 

It sounds like you didn't add the extension import policy to the correct location in platform-settings.json.  If should be under PlatformSettingsConfig as in this example:

{
    "PlatformSettingsConfig": {
        "AdministratorUserSettings": {
            "InitialPassword": "PtC@1234567890"
        },
        "ContentTypeSettings": {
            "supportedMediaEntityContentTypes": [
                "image/svg+xml",
                "image/png",
                "image/gif",
                "image/bmp",
                "image/jpeg",
                "application/pdf",
                "image/vnd.microsoft.icon"
            ]
        }
    },
        "ExtensionPackageImportPolicy": {
             "importEnabled": true,
             "allowJarResources": true,
             "allowJavascriptResources": true,
             "allowCSSResources": true,
             "allowJSONResources": true,
             "allowWebAppResources":true,
             "allowEntities": true,
             "allowExtensibleEntities": true
        },
    "PersistenceProviderPackageConfigs": {
        "MssqlPersistenceProviderPackage": {
            "ConnectionInformation": {
                "driverClass": "com.microsoft.sqlserver.jdbc.SQLServerDriver",
                "jdbcUrl": "jdbc:sqlserver://localhost:1433;databaseName=thingworx;applicationName=Thingworx;",
                "password": "twadmin@12345",
                "username": "twadmin"
            }
        }
    }
}

 

If it's a syntax error, you can validate the syntax in platform-settings.json at this site, or provide your platform-settings.json here for review.

 

Regards.

 

--Sharon

 

 

hjimene3
6-Contributor
(To:slangley)

It was a missing comma, indeed. I appreciate your help slangley!

Top Tags