cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Community Tip - Need help navigating or using the PTC Community? Contact the community team. X

kepserver runtime error

M_Heidari
4-Participant

kepserver runtime error

Hi everyone

Actually I got a serious error in Kepservers v6 and I would be grateful if anyone could help me to find out this problem.

It can be helpful to describe a bit about our project. We have 3 gateways with kepserver in each one and of course a server that received data from getaways by Cimplicity software. Here we have nearly 800 devices that are divided between these 3 gateways (3 kepservers). Almost each device is assigned to one channel.

I have been working with this project since 3 years ago and over this time I added devices gradually. Everythings was ok untill last year that I got an error in kepservers when one of our Kepservers fails, then the two other Kepservers also fail. It means all tags values in all devices become constant or bad (out of service) and the project couldn’t reconnect so we reset project by reset windows service runtime in Windows Task Manager. But it disturbed again in 2 hours. resetting systems doesn’t help too. To solve this problem ,we

  1. checked all fiber connetions
  2. deleted all extra tags those we didn’t use in device to reduce projects size.
  3. merged some devices in one channel to reduce number of total channels that are seen by server.

after nearly 3 weeks it solve and I wasn’t sure if the problem was solved by one of above solutions.

Now after one year it happen again and the problem apears in all 3 kepservers and i couldnt find it out yet. and as I lost all datas in my server, It’s important to find the basic problem.

Thank you for time. I look forward to reply.

1 ACCEPTED SOLUTION

Accepted Solutions
M_Heidari
4-Participant
(To:M_Heidari)

Hi everyone

I think I’ve found the problem

Although I thought all connections were ok, one of main switched had lots of interruption in its connection. This switch sends data from some devices to 3 Kepservers so as soon as these devices connected, all 3 systems were impressed by that.

.

View solution in original post

3 REPLIES 3

@M_Heidari ,

 

This sounds like a license issue.  After a license expires, Kepserver will only run for 2 hours at a time until the license is restored.  When this happens again, be sure to check the license utility to see if the license is indeed expired and needs to be updated.

 

Nick

M_Heidari
4-Participant
(To:nmilleson)

Thank you for your response

I cheked kep licences in all systems and they were not expired and the status was good in them. Could this problem be caused by setting in  specific swiches or relays?

that looks interesting all 3 kepserver got this problem Simultaneously

M_Heidari
4-Participant
(To:M_Heidari)

Hi everyone

I think I’ve found the problem

Although I thought all connections were ok, one of main switched had lots of interruption in its connection. This switch sends data from some devices to 3 Kepservers so as soon as these devices connected, all 3 systems were impressed by that.

.

Top Tags