cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Creo 4.0 Won't Open

Guest

Creo 4.0 Won't Open

Hi, 

I've downloaded Creo 4.0 as I'm currently studying at university and this program is made available to us for free. I installed it as prompted, used the license key which I was given and everything installed as it should. I disabled my antivirus during installation as prompted to. After the installation, I cannot seem to get any of the applications to open - the one which I need to use is Parametric 4.0 M030. I double click on the application and I get a loading symbol for about half a second and then nothing happens; I've tried the other applications which were also installed (Layout, Simulate, Direct and also the Modelcheck). The modelcheck is the only thing which seems to actually do anything but all that does is open a command prompt window for about a quarter of a second. 

 

I am running Windows 10 on a high spec gaming computer so it is very able to run these programs. Someone help please! Thanks in advance.

7 REPLIES 7

Re: Creo 4.0 Won't Open

Couple of points to check: 

 

1. Is xtop.exe available under installtion location of Creo 4.0, (C:\Pro.............M030\Common Files\x86e_win64\obj).

2. Aftre double click on icon do you see xtop.exe under processes in System task manager.

3. Rignt click on Creo icon and check startin from properties, browse to stratin and check if there are any recent trail file.

Re: Creo 4.0 Won't Open

Hi, thanks for responding. 

I've found the xtop.exe file, however when I double click it I get a system error message saying 'The program can't start because xercesc280mt.dll is missing from your computer. Try reinstalling the program to fix this problem.' Any ideas? I definitely disabled my antivirus which means that it didn't remove any files during installation. 

Sorry I don't understand what you mean in your third point, which Creo icon do you mean?

Re: Creo 4.0 Won't Open

Highlighted

Re: Creo 4.0 Won't Open

I have the same issue. The installation has been running successfully, and suddenly stopped working. I am pretty sure that a Windows update occurred since the last time I used it. I have tried adding the graphics win_gdi to my config.pro - no change. If I execute xtop.exe directly, I get the error about xercesc280mt.dll not found. I have uninstalled Creo and re-installed with no change. If I search for the missing dll it is present.

 

There isn't much to be found via google - this is one of the few threads so I am hoping it is still monitored. I use the educational version for FIRST FRC. With kickoff coming in a little more than a week it is a huge issue for me now!

 

Thanks for any help you might be able to provide.

Re: Creo 4.0 Won't Open


@puetzcraig wrote:

I have the same issue. The installation has been running successfully, and suddenly stopped working. I am pretty sure that a Windows update occurred since the last time I used it. I have tried adding the graphics win_gdi to my config.pro - no change. If I execute xtop.exe directly, I get the error about xercesc280mt.dll not found. I have uninstalled Creo and re-installed with no change. If I search for the missing dll it is present.

 

There isn't much to be found via google - this is one of the few threads so I am hoping it is still monitored. I use the educational version for FIRST FRC. With kickoff coming in a little more than a week it is a huge issue for me now!

 

Thanks for any help you might be able to provide.


Hi,

maybe CS258965 document will help you ... see attachment.

1.] download https://support.ptc.com/images/cs/articles/2017/06/1497624418CabD/CS258965_WA_files.zip

2.] unzip

3.] rename Creo original parametric.exe file (in Creo Parametric\bin directory)

4.] copy parametric.exe file acquired from zip file to Creo Parametric\bin directory

5.] launch Creo


Martin Hanák

Re: Creo 4.0 Won't Open

Again, thank you for your response. Here is more information about my issue.

The computer is a Microsoft Surface Pro 3 with an i7 processor, 8G memory, and Intel HD Graphics 5000. It is running Windows 10 version 1803 and the update manager says the OS is up-to-date. I have not installed that latest 1709 build due to the many problems reported on the Internet.

 

I am running Creo v4.0 M20, and have been for about 16 months. The license was renewed earlier this fall (Educational license used in conjunction with FIRST FRC). I like this version because it corresponds to the version that my employer uses, so it is convenient for me.

 

I have had Creo work, and not work 3-4 times over the past several days. When it fails, I get no messages, and no trail file is generated. If I run xtop.exe directly, I get a message about xercesc280mt.dll missing (along with some others). If I search for the "dll files", they are present in what appears to be expected locations. I have completely uninstalled Creo, and reinstalled with no obvious effect. I have only one license file, and use a hard-wired network connection.

 

I thought that adding the -g:win32_gdi to my startup command (and also adding the line DISPLAY win32_gdi to my config.pro configuration had resolved the issue, but today I am again unable to start Creo.

 

I did not try the CS258965 that you send as the file appears to be for Creo 3.0 and the text indicated that the issue should have been resolved in my 4.0 M20 build. With my academic license, I do not have acess to the PTC support website.

Re: Creo 4.0 Won't Open

Update:

Because I found the download link, I decided to try updating my Creo 4.0 M20 installation to the M60 release. So far, this seems to have worked. At least for now, Creo 4.0 M60 is running properly on my Surface Pro 3 computer. BTW, the update removed the win32_gdi items that I had added to the startup command, and to my config.pro. Since the software had previously been running w/o these restrictions, I doubted that they were needed but this seems to confirm that.

 

Doesn't help @ssubham16, however.

Announcements
Welcome to PTC Academic!