cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Graphics slow on many different computers

Highlighted
Level 1

Graphics slow on many different computers

I have an installation of Creo 2.0 Academic Edition on about 200 workstations with a floating license server.

Whenever I first load Creo on a freshly imaged machine, the graphics are crazy slow even on simple geometry. Just mousing over a simple cube causes the computer to slowly render the wireframe for about 5 seconds and Creo completely frozen until the process completes. Once I paste graphics win32_gdi into the config.pro file, it the problem seems resolved.

We've been teaching Creo/Pro-E since Wildfire3 and have run into this same problem in every version (since WF4) with many different computers including my personal computer which is an Intel i7 machine with 6gb of ram and dual nvidia graphics cards. The computer that I'm currently teaching with is a Core2 Duo Dell with 2gb of ram and a Radeon X1300. It's a little dated but I have to imagine that it can handle the simple geometry that I'm teaching to high school students.

Attached is a screenshot taken while Creo is choking on the graphics of an imported STEP file. The exact same thing happens on parts and assemblies created in Creo.

My questions are:

What does the graphics win32_gdi line actually do?

And...

Once graphics win32_gdi is inserted into the config.pro file, is Creo taking advantage of any hardware graphics acceleration?

11 REPLIES 11

Re: Graphics slow on many different computers

Matt,

You should only use the win32_gdi option as a last resort. It turns off Creo's use of the graphics card and instead uses the processor. For most computers, updating the graphics driver fixes the issues you are seeing.

This document explains the various graphics options and preferred method for using them: http://apps.ptc.com/schools/references/support_creo2_graphics.pdf.

Regards,

Adam

Re: Graphics slow on many different computers

Adam:

  • I installed the latest drivers (still about 3 years old) and then Creo wouldn't make it past the splash screen.
  • Then I edited the graphics options in config.pro as it says in that PDF (added "graphics opengl" "use_software_opengl yes" and "!graphics win32_gdi") and the original problem returned.
  • Then I commented out the "use_software_opengl yes" and it wouldn't make it past the splash screen again.
  • Finally I commented out "graphics opengl" and uncommented "graphics win32_gdi" so I suppose that I'm back where I started.

Any other suggestions?

Re: Graphics slow on many different computers

What type of graphics cards do you have? If you are using the internal Intel HD cards, they are not supported and unfortunately, you'll need to run using the win32_gdi graphics.

Re: Graphics slow on many different computers

This is an AMD Radeon X1300 series card.

Re: Graphics slow on many different computers

I guess I could have seen that if I looked a little closer!

I looked around a bit, it appears that as you probably already know, those graphics cards aren't supported on Win7 nor are the drivers being updated. Please send me a support request from the bottom of the Request Support tab at http://www.ptc.com/go/academic-support, I'd like to jump one one of them and take a look.

Thanks,

Adam

Re: Graphics slow on many different computers

The Intel HD4400 graphics card supports OpenGL 4.3 however freezes for approx 15 seconds on commands like "delete old versions" or "file rename". I have inserted config line graphics win32_gdi and everything works very fast with the exception that the model highlight is poor, for example when a part in the background is pre highlighted it blocks everything in front of it.

Any solutions to problem of partial freezes on the "delete old versions" or "file rename" command when using OpenGL. There are other commands which cause this 15 second freeze also but the above are the ones I have seen recently.

Thanks,

John

Re: Graphics slow on many different computers

The Intel HD4400 is not supported, even if it does use OpenGL. There is more to a graphics card then just the software the card is using or drivers.

Re: Graphics slow on many different computers

The delays on "delete old versions" and "file rename" are not due to the graphics card. they are from Creo being busy doing something else, in this case setting up the software and making some database connections to support the operations you are asking for. This is especially true if you are linked to Windchill.

Because those operations were not actively being used, Windows may have swapped the code to perform them out of memory to swap space on disk and Windows is taking a moment to swap out some software that is in memory to disk to make room to bring the software you are looking asking for back.

You might look into the MS utility Process Monitor, part of Sysinternals http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx

Re: Graphics slow on many different computers

David,

Thanks for reply. I certainly thought the same as you at first but when I set graphics to basic graphics win32_gdi the problem disappeared?

Thanks,

John