cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

2001i - version 15 compatibility

SOLVED
Highlighted
Newbie

2001i - version 15 compatibility

I have mathcad 2001i which I am finally forced to upgrade because it won't work on my 64-bit windows 7 computer.

Will mathcad version 15 open 2001i files (.mcd)? If so, will they be usable with minor editing or will there be a lot of work required to get them working right?

(I read that version 15 will not save in 2001i format so it makes me think that maybe it won't open 2001i files either.)

Tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: 2001i - version 15 compatibility

I have just opened the file with no error messages.

I have attached a few images of the graphs and results tables so you can check if the answers came out the same.

Mike

View solution in original post

10 REPLIES 10
Highlighted

Re: 2001i - version 15 compatibility

I believe it will open the file but only save down to version 14. I think you would need version 11 to save down to 2001i, but I'm not entirely sure. You could post an example and I'll try opening.

Richard to name one collab has muliple versions - you might want to wait for his reply.

Mike

Highlighted

Re: 2001i - version 15 compatibility

Good idea. I am attaching one of my mathcad 2001i files. If someone with version 15 can open it, it will answer my question.

Highlighted

Re: 2001i - version 15 compatibility

I have just opened the file with no error messages.

I have attached a few images of the graphs and results tables so you can check if the answers came out the same.

Mike

View solution in original post

Highlighted

Re: 2001i - version 15 compatibility

Thanks.

It looks like version 15 opened the files OK and the output format is still the same. (I had big problems with this when I changed from mathcad 7 to 2001i back in 2002 which is why I was afraid to upgrade after that.) I hope you get a commission because you probably just sold a copy of Mathcad 15!

Highlighted

Re: 2001i - version 15 compatibility

It looks like version 15 opened the files OK and the output format is still the same. (I had big problems with this when I changed from mathcad 7 to 2001i back in 2002 which is why I was afraid to upgrade after that.)

I'm glad it works and your happy. Version 15 is a good version.

I hope you get a commission because you probably just sold a copy of Mathcad 15!

I'm afraid not. If you purchase the new product Mathcad Prime you get Mathcad 15 with it.

Mike

Highlighted

Re: 2001i - version 15 compatibility

Mike Armstrong wrote:

I believe it will open the file but only save down to version 14. I think you would need version 11 to save down to 2001i, but I'm not entirely sure.

M15 will save down to M11, Mike. Unfortunately, I've had to remove my M14 so I can't check what version it will save down to, but I'm reasonably sure that M13 would have handled M2001i.

Stuart

Highlighted

Re: 2001i - version 15 compatibility

According to version 14's "save as" pull-down menu, version 11 is as far back as it goes.

Highlighted

Re: 2001i - version 15 compatibility

Mike Armstrong wrote:

I believe it will open the file but only save down to version 14. I think you would need version 11 to save down to 2001i, but I'm not entirely sure.

M15 will save down to M11, Mike.

Typo well spotted, it should have said 11.

but I'm reasonably sure that M13 would have handled M2001i.

Never had the pleasure of using M13, my employer jumped from 11 to 14.

Mike

Highlighted

Re: 2001i - version 15 compatibility

Versions 2001i, 11, 12 and 13 can save to 2001i format. Later Mathcad versions (with the exception of Prime) can always read files created with earlier versions. Although they can always read them, there may be compatibility issues though. Most 2001i files will run in 15 with no modifications at all. Some files will require changes, but usually they are minor. A few files may not run, and may not be fixable at all. That really is a few though, and the problem will be associated with one of only a few things: changes to the way user DLLs work, deprecated extension packs, Static Unit Checking, or the speed of execution of scripted components.

Highlighted

Re: 2001i - version 15 compatibility

Good post Richard, cheers for clearing that up.

Mike

Announcements