cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

Formatting Results in MC15

RobertStowe
1-Newbie

Formatting Results in MC15

Till now I have been using MathCad 13 on Windows XP. I downloaded the MathCad 15 on trial basis.

I am seeing strange behavior regarding the formatting of unit exponents in results. I can create a simple worksheet in 13 to show a variable as a result. It looks normal. If I open the same file in 15, it apears that the exponent inherits the formating of the number in front of the units. So if the number in front of the units is in exponential notation, the unit exponents will be in exponential notation as well.

MC13 rendition of file:

MC13 Image.JPG

MC15 rendition of file:

MC15 Image.JPG

This is crazy and hard to read.

Do anybody know what is going on or how to fix?

Thanks,

rwstowe

20 REPLIES 20

I have found that by manually entering the results units, things get back to normal.

Does anybody else have this problem?

I don't have M15, but that problem should have been fixed in M14.

I see the same result in Mathcad 15, so I'll log it.

Mona

RichardJ
19-Tanzanite
(To:mzeftel)

It should already be logged. It's an old bug that has come up many times. I'm surprised it hasn't been fixed.

I see this in MC 14 when the region's significant digits for display are set with trailing zeroes turned on.

My bad, it apparently hadn't gotten fixed, although I show the problem reported and logged Sept 15, 2006. Apparently, it was easier to break the system than to fix it.

Eden,

Pardon my ignorance, but what do you mean by "break the system"?

rwstowe

Yes,

i´ve the same problem,

is there a solution available?

thanks

MikeArmstrong
4-Participant
(To:Worf)

Can you post an example of your problem image or worksheet.

Mike

Sorry, i didnt found a way to insert a screenshot

Hans

MikeArmstrong
4-Participant
(To:Worf)

When you create a post there is a camera icon which is the link to insert an image within a post. You can also upload an file at the bottom of the page.

Other than my post on 7/15 at 4:30PM, I don't have any helpful information. I haven't heard of PTC correcting this bug yet.

As you wrote, this is broken in MC15. We have not yet prioritized fixes for the next maintenance release.

However, I just checked the same results formatting in Mathcad Prime 1.0, and it works correctly.

Mona

Worf
1-Newbie
(To:mzeftel)

Here is an example

MikeArmstrong
4-Participant
(To:Worf)

Am I missing the point?

Example.jpg

Mike

That's not what I see

formatting.gif

Maybe I should have said I redefine the unit .

Not right but is a workaround.

Mike

How did you redefine it?

And what's with the ever changing Avatar? You're giving me a headache!

http://communities.ptc.com/servlet/JiveServlet/showImage/38-1286-11144/wobble.gif

How did you redefine it?

Just type the desired unit in the placeholder and the unit automatically generated by Mathcad.

And what's with the ever changing Avatar? You're giving me a headache!

http://communities.ptc.com/servlet/JiveServlet/showImage/38-1286-11144/wobble.gif

Sorry, no more changes now. I have found the one.

Mike

Just type the desired unit in the placeholder and the unit automatically generated by Mathcad.

OK, now I see what you mean. Yes, for now that's a good workaround.

Sorry, no more changes now. I have found the one.

Sure! I believe you. Until it changes again, that is

Announcements
Check out the latest
Mathcad Tip
"PTC Mathcad 15 / Prime 1-6 Update."