cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 

How to convert Legacy files from Mathcad versions 2.0 to 15.0 to Prime2.0?

rsaxena-2
1-Newbie

How to convert Legacy files from Mathcad versions 2.0 to 15.0 to Prime2.0?

How to convert Legacy files from Mathcad versions 2.0 to 15.0  to Prime2.0?

I have thousands of files and ebooks like Roark Formulas.  How I can read into Mathcad Prime 2.0?

Any Help would be appreciated.

Thanks,

Raman

6 REPLIES 6

Unfortunately Prime can't read older Mathcad files on its own. The files have to be converted to the new format. You may have noticed the appropriate menu in the ribbon or the link to the stand alone converter in your program collection.

For the converter to work you must have a current version of mathcad 15 installed on your machine. If you have a license for Prime the same license is valid for Mathcad 15, too. You can download Mathcad 15 here: Thank You for Your Interest in PTC Mathcad 15 | PTC

You may stop after installing MC15 and keep working with that version as Prime 2 sure is a software you really should ban from your computer. Its not worth working with as its an inferior version. Prime 3 may be a very little bit advanced but still lacks a a lot of features and can not live up up to MC15.

If you insist on converting your library to Prime format you have to be aware that unless you have rather basic functions in your sheet, the converted sheet may not work at all or will at least need a lot of hand tuning. Also older versions of Mathcad are more capable and support more featiures so a lot of things simply cannot be convverted as there is no equivalent in Prime.

Good luck anyway

Werner

EDIT: I am not sure how far back Mathcad 15 can read older files.

The files you attached seems to stem from the DOS 2.5 version of Mathcad and  I thought that Mathcad 15 should be able to read those files. But I just tried and my Mathcad 15 seems to have troubles readibg that file.

LucMeekes
23-Emerald I
(To:Werner_E)

Mathcad (not Prime) can read all previous versions (e.g. Mathcad 15 can read Mathcad 2.01, like the one attached) and will sometimes mention that it's an older file.

Luc

> Mathcad (not Prime) can read all previous versions

Thats exactly what I thought, too and indeed I have no problems opening your Bode.MCD.

But when I try it with the Cubic.MCD provided by Raman, Mathcad 15 "hangs" after confirming the information window that the file was created by an older version and after a while Mathcad will crash. Not sure whats the case.

RichardJ
19-Tanzanite
(To:Werner_E)

I get the same behavior.

LucMeekes
23-Emerald I
(To:RichardJ)

That's because the file is incomplete. It ends with an introducer for an equation

"

.EQN 0 39 2 12

"

But the equation itself does not follow.

If you strip that last line, it opens without problems.

My guess: the file got corrupted, at least truncated.

Luc

Ah! Well observed!

Announcements
Check out the latest
Mathcad Tip
"PTC Mathcad 15 / Prime 1-6 Update."